m2m embedded application tutorial


#1

Hello,

I am having problems working through the “Develop an m2m application end-to-end within 4 hours” tutorial (developer.sierrawireless.com/en/ … skill.aspx).

I have an FXT009 device and have the latest Developer Studio (2.3.0) installed.

My first problem is that I cannot find the “Models Explorer” view that is needed for the “Creating models in the Open AT - Developer Studio platform” section of the tutorial.

My second problem is that when I try and create the demonstration project, no toolchains are available to be selected. I think this is because the Target Platform Configuration dialogue has the warning
“This package ReadyAgentR5 Plug-in Package (5.1.0.I201107281559) is not compliant with the selected Framework profile Open AT Framework package (2.51.0.201206190958)”

Is this tutorial simply out of date? If so, is there a similar, newer tutorial?

Andy


#2

I have solved my first problem - I hadn’t realised that there was separate “Developer Suite for Operating Portal” Eclipse tool.


#3

Hello everybody,

I am new to this and maybe you can help me. I tried the tutorial link in the first post of this topic but there was no tutorial (check attached image). I wonder if you could provide any other link for the file.

Thanks for your help


#4

Hello Andres,

The tutorial referenced above is no longer pertinent, because it uses AirVantage 3 former M2M platform. We’ve removed it and replaced it by new ones compatibles with AirVantage 4 M2M Cloud. See Get Started section.

Tell me if the new ones work for you.

.Thibault.


#5

Thank you for your help Thibault,

I have checked the link and I already had that one and the hello world video. What happened is I had been having a look at the forum and a 4 hours start up tutorial seemed intersting as I am having some trouble with the rs232 connection of my fxt009 and I thought I may find something I had missed on that tutorial (usb works fine but I cant even open the serial port. I am about to make a 9 wire cable now just in case I need more than CTS and DTS).

best regards