Bricked my EM7455 / DW5811E

Hi all,

I installed the EM7455 / DW5811E in a dell e5270 and it seemed to work with ups and downs.
Therefore I had the stupid idea to update the firmware from the sierra website to the latest version.
Now the device seems to be locked for rogers when I check with the skylight tool.
I tried everything (even reinstalling the pc) and it isn’t working anymore, not with native drivers, siërra drivers or dell drivers.
The ‘unlock sim’ message appears several times.
Is it possible to flash the device with other emea firmware (since i live in Belgium)?
Thx, Bram


I believe that module still not fully “brick” and able to access for AT commands. Please go through below site and got some ideas how to resolve current module status.

Hi, thanks, already tried that one but from the moment I’ve installed the dell drivers (step 1 and 2) and the modem is installed afterwards the firmware upgrade fails at 37%. Dell seems to use the Original siërra drivers btw. It’s a pity I can’t force an Original factory reset firmware flash.
thanks anyway, Bram