Upgrade firmware on module PCIe DW5811e (EM7455) ... after, PC not recognize module. BRICK

Hi. I have a DW5811e module on a dell e5470. After upgrading, the pc no longer recognizes the module. Any attempt to update the firmware (dell firmware, firmware taken from the sierra site) fail with a message "device not found). I tried to install the called “Generic” firmware first, but I think it was blocked. But in any case everything still worked So I decided to try the other firmware (TMO (Generic)) and after updating the latter, the adapter stopped working … honestly not so which one to download

the firmware I downloaded them from here: https://source.sierrawireless.com/resources/airprime/minicard/74xx/airprime-em_mc74xx-approved-fw-packages/#sthash.LC2LydW3.NlWPI0OV.dpbs

How can i do now?

is there still modem port in device manager?

unfortunately no…does not appear in device manager

Any port enumerated in device manager?

I’ll explain better. I did a lot of tests, installed various firmware and drivers (from the generic ones on the official Sierra wireless website, to those of DELL). After having “bricked” the module I followed the steps in the sierra forum where there was a user who said to proceed in two ways:

  1. Turn on the pc without module and put it on stand-by. Then insert the module inside (risky)
  2. Connect the module via an m2-USB adapter to the pc and proceed with this

Not having an adapter, I followed step 1 and fortunately I did not encounter any problems. So I was able to install the “Generic” firmware without any problems. Today, I try again to do a clean installation of the drivers / firmware and go back to the initial situation: the adapter is recognized without problems (even by windows in the device manager) but once again windows TELLS ME TO INSERT THE SIM! So I go back to searching the web and I discover something: on the Lenovo site (La scheda SIM potrebbe non essere rilevata con l'adattatore EM7345 - ThinkPad - Lenovo Support US) I find an exe package where it promises to solve this problem. So I try to install it (even if it is for Lenovo PCs and the firmware is not even EM7455 but EM7345!!) and BOOM … the adapter not only works correctly, but this time the sim is also recognized! I don’t know what the hell he did, but it worked! Why does updating with generic/DELL drivers not work while drivers even from another brand work? I took a couple of pictures from what little I could figure out from the AT commands:

PS: I tried to reset the adapter with the commands:


…and after reset, then this is what comes out:

So I decided to do it all over again (but without the Lenovo firmware).
I update the firmware to the latest version, I download the dell drivers and the sim once again is not recognized!

These other photos instead are after installing the firmware of the Lenovo:

these last photos instead are when the sim is not recognized (dell driver only):

Immagine 2022-01-31 213643