AT+COPS=? returns just OK, and the operator list after a while

The following happens with
Model MC7455, Revision SWI9X30C_02.24.05.06 r7040 CARMD-EV-FRMWR2 2017/05/19 06:23:09


+COPS: (3,"","TDG","26201",2),(1,"E-Plus","E-Plus","26203",2),(3,"","Vodafone","26202",2),(3,"","TDG","26201",7),(2,"o2-de","o2-de","26203",7),(3,"","Vodafone","26202",7),,(0,1,2,3,4),(0,1,2)

It seems, that this happens after a AT+COPS=1,2,“nnnnn” while the data connection is established.
Is this “unsolicited” result normal, documented behaviour, or specific to this firmware?
How can the modem be forced to regular scanning (besides power cycle)?


Not too sure what the procedure you are doing or what your objective is.

  • If you set at+cops=0 then the unit is set to scan automatically and select the operator it wants to.
  • If you send at+cops=? then the unit will scan all enabled tech and bands and then return this list of operators it can see on what technology. It is no different to asking your phone to perform a scan, you don’t drop the network you are currently on because you are scanning, equally doing anything else will cancel the scan.



Hi Matt,
yes. The regular way is as you describe: AT+COPS=? takes a while, maybe max. 2 to 3 minutes, then returns the operator list from scanning, and then “OK”. But in my case the command returns immediately with OK, and after a while the modem sends the operator list. This looks like other “unsolicited” modem answers. I have currently not found any way to get the modem back to the regular sequence.
It can be forced by sending AT+COPS=1,2,“nnnnn” or AT+COPS=2 while a data session is active.

Ok I see what you are saying, no that seems to be wrong. I have tested it and my unit seems to be doing as expected i.e. send at+cops=?, wait for a minute and the unit returns the networks then an OK.

What might be happening is that the command is abortable which means that if you send any character during the operation it will exit sending ok (to the abort) but then it might be outputting what it has already found. At a guess. Either way I cannot seem to repeat your behavior.