Application not starting


#1

Hi to al,

       Actually im using Wavecom Q24 extended for my project. I tried using M2M for the very first time.i carefully followed the cheat sheets to download the application in target mode.Initially i created a project then connected M2M studio with wireless cpu.For building my application in project explorer i selected the project, clicked the option Build Configurations->Set Active->2:[Target]_ARM_ELF_GCC_RELEASE. Now for launching the application i right clicked my project in project explorer i choose the option Run As->2.Open AT Application.Now i got a C local Application window.I selected the Binaries ***.axf and clicked ok and my code got downloaded.Now Target Monitoring Perspective opened automatically and in remote Shell i can see the commands and response

AT
OK
AT+WOPEN=1
OK

After these commands my code is not running. I tried in hyperterminal also.Dowloaded a dwl file which was previously working.I am succesful in downloading the files.but application is not starting.But it is responding to my AT commands.Please help me


#2

What, exactly, do you mean by that?

What do you mean by your AT commands?


#3

Hii

Try giving “AT+WOPEN=7” when you start your application. It will tell you what exactly is going wrong with the application. After the response is received for the command , try to check in the AT Command Guide regarding the reason.

Hope it helps… :smiley:
Regards, Paruthiv