How to download Open AT software?


#1

Hi gyes,

I have built an application and now I would like to download it to my Q2686 CPU so that it can run automatically each time the CPU is switched on.

I know the procedure thereabout but I have some questions:

  1. Can I download the software through Target monitoring tool? I saw there is such a button there but I cannot find any specification datasheet which explains the procedure. How can I do this?
  2. How is it possible to create the .dwl file to be downloaded to the CPU? I have checked all folders of my application and there is no such file created…
  3. Is it possible to delete afterwards the file downloaded to the CPU and how? (in order to download a new file)

Could someone suggest me which specification datasheets refer to these subjects, because I haven’t worked on Wavecom’s product for a long time and although I remember I have read something relative, now I searched but I cannot find it anywhere!

Thanks in advance!

Tatiana


#2
  1. If you are using M2M studio, you use download button on Target Management window. Just press it, select the file and the download will start fi you are connected with the module (Connect button). To run your application use AT+WOPEN=1.
  2. You create .dwl file when you build your application as “Target debug” or “Target release” it’s on a folder like “[Target]_ARM_ELF_GCC_Release” or “[Target]_ARM_ELF_GCC_Debug” (using M2M Studio).
  3. It’s not necessary. Anyway, you can delete it with AT+WOPEN=4 (stop it first with AT+WOPEN=0). If you are using flash or A&D objects, it’s good to erase them before downloading your new application (AT+WOPEN=3).

For more information use M2M Studio help window and the Cheat Sheets (on help menu).
Good luck. :smiley:


#3

Thanks fer.caballero, but infortunately I cannot find the “Target debug” or “Target release” as you said to build my application. I am using Microsoft Visual C++ and the options for building my application are:

  1. Application and Win32 Wismo Target
  2. Application rte and Win32 Debug or Win32Release

The thing is that although the build command is just ok in Application rte mode (Win32Debug), when I try to build in Application mode (Win32 Wismo Target) I get the following error:

" make: *** No rule to make target appli.o', needed bygcc_Application_H’. Stop.
Done.
[wmmake error #1] Build error.

Application - 1 error(s), 1 warning(s)"

What is wrong with this and what exactly did you suggest me to do? Have I misunderstood anything?

Thank you very much for your kind help!

Tatiana


#4

Sorry, I don’t use and I’ve never used for this isues:

I suggest to download M2M Studio, with gcc and Eclipse, and use them instead of Microsoft tools.


#5

Do you mean the M2M full package? Does it already contain gcc compiler and so on? The code that I have already written does not have to change?

My problem is that when I build my application for Wismo target no .dwl file is created in gcc/out folder, whereas when I try the same procedure with a sample (e.g. Telemetry) a .dwl is created! Do you think there might be a problem with the files I added to the project? Apart from the appli.c, I have added another two .h files and a .c file! What may be the problem!

Please somebody help me!

Thank you!


#6

Yeah. That’s one of the greatest things about Wavecom (in my point of view).

Don’t think so. I work with 8 *.c files and 10 *.h files in one project, and in other with 12 .c files and 12.h.
Any way, you got 1 error and 1 warning, try to check both. Some times, one error/warning hides, a huge stack of errors… If doesn’t work, try to generate again the project. `appli.o’ file is generated by the tools, actually if it’s not generated, you’ve got a problem with the tools or the project files.


#7

Thanks fer.caballero! You are right! No appli.o file is created, whereas in telemetry sample it is created!! I have tried many things and I think I have not included my src and inc files properly! How have you done this? I don’t know what is wrong with all this! What do you mean by

? What can I do to solve this problem?

Thank you very much for your kind help!

Ah!I forgot to tell that I tried to include files from the Open AT project wizard by writing to the wmnew scipt but no file appears in MV environment!


#8

If it works with the telemetry sample, I hope the problem has to do with the project files.

What I mean is the same you suggested, maybe you haven’t correctly include the files in the project. *.c files must be included in “src” folder, and *.h files in “inc” folder. I don’t know if any other solution works, but it has always worked for me.
Have you check the error and the warning you got?


#9

Yes, I do think that the problem lays in including files! But I don’t know what to do to achieve this, as I tried to include files trough the Open AT project wizard (-inc C:/…appli.h for example) and no such file appeared later at MV environment… In addition I have used the wip library, the use of which I declared in Open AT project wizard, but I don’t know if this is enough so as that the application works properly… Do you have anything to suggest me especially about the including files proceedure?

Thanks fer.caballero!


#10

Try with M2M Studio. You don’t have to pay for it, so if it doesn’t work it doesn’t matter… :smiley:


#11

Ok!I have downloaded M2M but when I run the .exe file, nothing happens! Could you please suggest me a reliable link, where I can donwload M2M?

Thank you again for your kind help!

PS: I hope I don’t have to change the code with M2M! :smiley:


#12

Try with the complete version:
http://www.wavecom.com/media/files/eclipseUpdates/M2MStudioLocalSetup.exe
Check you have a version of Java 1.6.X.
You are working with Windows XP?


#13

If you are not using M2M studio and want to use multiple files in project - you should modify make script of your project. It is relatively easy :slight_smile:
Also on every added file (and on initial build) use Rebuild All.
If you write #include directive, do not write path - all .h files are copied in the same root directory before compilation.


#14

Thank you fer.caballero! Yes I am working with Windows XP!

Blackyblack, what do you mean by saying:

Do you mean that I should write the -inc or -scr commands in wmnew script?Because I have already done this and no such files appear? Apart from this, when I create a new project using Open AT Project Wizard, no inc folder (even if it is empty) is created! What is going wrong?

Thanks guys!


#15

No, I meant .mac file in the root folder of the just created project.
I don’t use wavecom’s folder structure - it seems bizarre to me. I create a folder for every “module” of my program and put .c file and header of the module in one folder.
In make file you write a path for every used .c and .h file and during full rebuild all files on these paths are copied in one folder, compiled and linked.


#16

Thanks blackyblack for your kind help, but it didn’t work!
I have created two folders inside the src folder and put inside each one the .c and .h files respectiverly. I have opened .mak file from the root folder and changed the following:

[i]#------------------------------------------------------------------------------

Path for code C files

#------------------------------------------------------------------------------
PATH_C =
…/…/src \appli
…/…/src \NmeaParser

#------------------------------------------------------------------------------

List of source files of the library or executable to generate

#------------------------------------------------------------------------------
SRC_C_LIST =
appli\appli.c [/i]

In applil.c code, I have used #include appli.h and #include NmeaParser.h but unfortunately my application comes upr with an error when rebuilding all which says that it cannot find the appli.c file…

Could you please tell me what am I doing wrong? I think I have followed your steps, right?

Thanks!

Tatiana


#17

You are still doing it wrong. :slight_smile:

Write SRC_C_LIST without directories - just a list of .c files. Like this:

SRC_C_LIST =  \
appli.c \
global_vars_and_utils.c \

Write PATH_C as directories seen from within gcc directory. Like this:

PATH_C = \
../../src \
../../src/global_vars_and_utils \

OpenAT will scan this directories for .c files and copy it in one folder.

Write PATH_H exactly as PATH_C. OpenAT will scan the same directories for .h files.


#18

Ok, thanks blackyblack for you help! The thing is that I tried your option but it still didn’t work, so I had to create an “inc” folder inside the root folder of my application and put there the .h files, whereasall .c files were placed inside the src folder ()just like in sample applications!).

The thing is that although in rte mode evrything is build okand the application runs normally, when I try to build in Wismo target mode, I get three errors:

[b]---------------------------------------
… Dependency graph is being built …
…/out/gcc_eBraceletappi_H.dep
In file included from …/…/src/appli.c:5:
…/…/inc/appli.h:23:24: wip_bearer.h: No such file or directory
make[1]: *** [depend_c] Error 1
make: *** […/out/gcc_eBraceletappi_H.dep] Error 2
Done.
[wmmake error #1] Build error.

eBraceletappi - 3 error(s), 1 warning(s)[/b]

and no .dwl file is created inside the gcc folder, so as to download it to my CPU!

Do you have anything to suggest me about this please? I would be grateful!

Thanks in advance!

Tatiana


#19

It seems that you have not correctly included WIP plug-in for your project. Check your plug-in path in the same .mak file if it is correct and really contains WIP header files. Also, it is better to include once just wip.h and do not include each of its components like wip_bearer, wip_tcp etc.


#20

Also run Rebuild All task for target mode. Or Clean and the Build All.