ALX40 error when receiving SMS command after fw upgrade

Hi all.
I just upgraded my ALX40 to the latest ALEOS SW and radio fw:

ALEOS Software Version: 4.16.0 ALEOS Build number: 021
Device Model: LX40
Radio Module Type: WP7607 Radio Module Identifier: GENERIC
Radio Firmware Version: SWI9X07Y_02.37.03.05 52ddef jenkins 2021/12/22 04:24:24
The SIM provider is Vodafone Italy.

PROBLEM: I got the following error whenever I receive SMS command (it seems it cannot parse timestring after fw upgrade?!)

Feb 13 15:10:25 err ALEOS_SERVICES_SMSPROC: Unable to convert gpsHH, gpsMM, gpsSS to integer
Feb 13 15:10:25 err ALEOS_SERVICES_SMSPROC: handleSMSControlCommands: Response for STATUS failed -1
Feb 13 15:10:25 err ALEOS_SERVICES_SMSPROC: handleQCONMessages: Control command processing failed
Feb 13 15:10:25 err ALEOS_SERVICES_SMSPROC: runSMSProc: QCON message processing failed with error -1

My SMS service configuration (Control Only with trusted phone numbers set)
SMS Address Type = International
SMS Address Numbering Plan = ISDN/Telephone
SMS Technology 1 - Circuit Switched
SMS Message Format = Default

Any idea/suggestion? I already tried changing the SMS service configuration but nothing works.
Thanks in advance for any help!

UPDATE: I did many tries but all failed. Router fails in handling the response to the STATUS SMS message, failing in the conversion of gpsHH/gpsMM/gpsSS time fields to put in the answer. Before firmware upgrade (old version 4.9.5) it worked smoothly. Any idea how to fix/solve this issue please? Any suggestion for trying some test out? many thanks in advance

Hi @techcom

Could you please share with me some information as below:

  1. Please make sure the SIM card in your LX40 Airlink can receive messages from outside, you can try to insert this SIM into the phone to see if it receives the messages. Besides, after inserting the SIM card into the LX40 Airlink, please check the network state.

  2. Please describe clearly what is the purpose of receiving SMS commands?

  3. Please share with me screenshot of the SMS tab in ACEmanager.


Hello! Thanks for replying.

  1. Yes the SIM is working, and signal is good. It’s a remote installation I did, I can connect via SIM/internet and it receives SMS messages (for example command “&&&relay 1 1” works ok. It fails in sending back a response if I query its status with command “&&&status”. I tested with another ALX40 with ALEOS version 4.14 and it works, if I upgrade to 4.16 it fails. I attach the logs, you can see it gets error in formatting timestamp for the outgoing sms of answer. Quick SMS test works too, It replies correctly to the relay order too. It just fails when it has to answer with timestamp.
  2. Customer uses SMS to query router status and to send other commands, in particular to switch on/off an attached device with the relay connection.
  3. I attach a screenshot of SMS tab and error log. I tried to change options/parameters in the advanced section of SMS configuration but it seems nothing works.

Hello @jerdung and all, I dont know if it can be useful but i did test with different LX40 models and i can confirm if i change nothing but just upgrade from 4.14 to 4.16 I got the same error of the previously attached screenshot from the router when it tries to send back to my mobile the SMS with the status information as requested by my command &&&status. Anyone else got the same issue or may have a quick try? I am stuck since i cannot move back to 4.14 and now i have more lx40 not working anymore :frowning: … many thanks

Hi @techcom
Please disable the Trusted Phone Number feature temporarily, then use the same configuration as me as shown below. Do the issue still happens in this case ?
I tested your case on my LX40 with ALEOS Version 4.16.0 and I didn’t observe the your issue.


Many thanks @jerdung for your support! unfortunately I am getting the same error (i attach screenshot). I have Wakeup section in addition to yours, dunno why. The error “Unable to convert gpsHH, gpsMM, gpsSS to integer” is still the one faulting the sms procedure… could it be some parameters somewhere else affecting this procedure? I tried enabling/disabling NTP (guessing the system takes the time from there? gpsHH? i do not have any gps nor gps settings on LX40 though… any other idea or tests i can try? many

thanks again

Hi @techcom
I would like to summarize your issue as follows:

  1. Your issue happens only on latest firmware but not on older firmware
  2. You have also configured the parameters to default values but the issue still happens on latest firmware
    So, I think it’s better in this case, please email tech support: for further support.


@jerdung many thanks to you for your time and help!