Wavecom Q24 OpenAT SDK


#1

Hello,

Recently I’ve been asked to give support to an old project that uses the modem wavecom Q24 plus.
I tried to do some research and seems like the software was developed using a combination of Visual studio (not sure what version) and OpenAT sdk. The thing is that I can’t find the sdk download file anywhere.
Does anyone know where I can download this file? According to some threads here I need to contact a distributor, could anyone supply the contact info?
Not sure if the openAT was free or if it was paid. If someone wants to share some hints on how to approach the problem it would make my day, I’m a total newbie when it comes to openAT and Q24plus


#2

@msantosvps,

Would suggest being a newbie trying to maintain a project on a product that has been dead forover 5 year is not the easiest thing to do.

Probably the best thing to do would be to download the openAT dev studio from the link below that is compatible with the older units (think it will be compatible with the Q24).

http://updatesite.sierrawireless.com/installer/Open_AT_Application_Framework_Light_Installer_v1-3-5.exe

Then you will need to find the version of Open AT they were using, we do not have these versions posted anywhere any more as they are so old but if you find out we will see what we can do to find it.

Regards

Matt


#3

Thank you for the reply.
I attempted that before posting the question here. That version doesn’t seem to support the modem Q24 Plus.
When I try to create a new project the options that appear are:

  • Fastrack Xtend
  • Q268X
  • SL608X
  • SL808XT

None of these seem to be compatible with the modem I want. Also the original project was developed using visual studio c++, if I could find the version that didn’t require me to change IDE would be even better.
Could you tell me what was the last version of openAT supported on visual studio and if possible a download link?


#4

@msantosvps,

That information is so old now it will be lost to time, it would take a lot of wading through old filesto figure it out. I never set Visual Studio up but technically you could use any of the versions with it as it was just building an application using GCC.

As a basic first step you need to know the version of OpenAT used as without this you cannot get the initial package defining API’s, etc. As I have said we no longer have an on line repository for this as literally no one uses it anymore since we have not manufactured the unit for over 5 years.

Regards

Matt


#5

Looking at the source code I have, the version used is Open AT 3.14.03
If you need some specific file or any other info, just ask and I’ll try to see if I can find it.
It would help me a lot if I could find the installer, otherwise fixing the bug I’m trying to fix will be almost impossible.


#6

@msantosvps,

Hmm I have found a 3.14 (not 3.14.03) but the package is 345MB, this will contain the full SDK as well, its 12 years old!!

Regards

Matt


#7

That must be right, since the last compilation date was 2009.
I found 2 versions on the logs that refered paths (since I don’t know another way to check the version):
Seems to use OpenAT 3.14.03 and ARM compiler 4.0.1.0.

I tried to attach the log file but apparently I don’t have enough permissions on the forum to do it yet
Could you give me a link to download the SDK? The compiler is also included in that install file?
I’m willing to give that version a try and see if it works, hopefully the differences between 3.14 and 3.14.03 aren’t anything major.
What’s the newer sdk you have released after the 3.14 version?

Again thank you for your help


#8

@msantosvps,

In the old days SDK’s were generated per release and while they were pretty similar between releases they were married together so you could not have multiple Open AT OS’sin a single SDK on your PC, it was very painful.

Re getting it to you not sure how to do that given, as I have already said, it is not posted ANYWHERE publicly and my ‘broadband’ is stuck in the dark ages (374MB at less than 1Mbps = long time). Will see what I can do.

Regards

Matt


#9

@msantosvps, sent you a link privately to the SDK.

Regards

Matt


#10

I already downloaded the files and tried to compile the project. Turns out finding Visual Studio C++ 2003 is a nightmare to find nowadays… But I managed to find it after a lot of google magic :slight_smile:

But sadly I can’t compile successfully quite yet. The openAT folder using the SDK you gave me has this versions on it:
OS/3.13.02
WIP/2.00.31

And the project dependecies are expecting this versions (wich are newer):
OS/3.14.03
WIP/3.10.1030

I tried to replace dependencies for the versions I have but I ran into an issue with this file:
C:/OpenAT/Plug-ins/WIP/3.10.1030/WIP/rte_wmwipSoft_3.10.1030.lib

It doesn’t seem to be an equivalent file using the sdk you gave me. I was almost seeing the “Build successfully” in my head :frowning:

You have any newer sdk I can try? This one seems to be older than the one used.
Sorry for being a bit annoying with all the requests, if it’s easier you can give me multiple SDK and I’ll try to figure out which one works.


#11

You have any news on the SDK?
If it’s easier for you just throw a bunch of versions and give me the link and I’ll try them all until I find the correct one. Because I don’t know another way to acess the specific SDK version besides the folder names in the project


#12

Hi again mlw, did you have a chance to look at the issue yet?