WARNING! Undocumented internet protocol feature!


#1

Hello,

Let me tell you my latest encounter with an undocumented fantastic new brainiac feauture invented by Wavecom (thank you). It’s called probably “internet protocol feature”.
I was sitting in my chair calmly and started run my ftp program on OS 4.10 with WIP 2.0.0.2 (it was tested months ago with 2.0.0.1 well).
The program called the ftpCreate() function and nothing happens. (the return value was OK, no messages in the handler function) I say “what the hell”, and my calm started to dissappear…

After two hour s*****, i finally managed to get a TRACE message on the window, which looked like this:

???

There is no mention about Internel Protocol feauter in the provided documentum (OAT 4.10, 4.11), but obviously the programmers knew that.

Luckely i found a module (it was provedid with my starter kit half year ago) which probably has this feauture, and the ftp worked.

Nice christmas present, thank you wavecom…

update:
You can check whether the internet protocol feature is activated with AT+WCFM=5. It has the same code as the high level, low level internet concept in OS 6.55. Obviously the OS 6.6x inherited it (i presume OS 6.57 as well), but wavecom forgot to inform the users (and my distributor) about it… (Funny, because currently the WIP function’s has no return value regarding the reduced IP functionality)

merry christmas to all of you!

tom

p.s:

Really annoying that this platform could be really good with a little more care.


#2

I´m 100% with you tomalex. There are a lot of undocumented features and bugs in wavecom plataform, neverless it could be a realy good plataform with really fast implementation/market time.
merry christmas and a happy new year for all,
Sérgio


#3

Dear Tomalex and sergiofernando,

We have constructively taken your suggestion into account and would make sure that all the problems that are encountered by you are corrected as soon as possible.
The change in the documents would be made which would tell the user that the feature is not enabled.

We thank you for pointing out this problem.

Hope you have a great time in Open AT Forum.

Best Regards,
The Moderator.