HTTP CLient Error


#1

by starting http client sample application i get this:

[GPRS]: open: -> DISCONNECTED
[GPRS]: start: -> CONNECTING
[GPRS]: GPRS EVENT SETUP OK (cid=1): GPRS activate

+WBCI: 3,3709
[GPRS]: GPRS EVENT: 27 (cid=1)

+CGREG: 1

+WBCI: 3,3709
[GPRS]: GPRS EVENT ACTIVATE OK (cid=5)
[GPRS]: GPRS: -> CONNECTED

HTTP Client Service test application : Init
ERRLOG http.c:120: Internet Protocol Feature not activated
cannot create http session channel

what does it mean ?


#2

Hiya,

It means exactly what it says - your modem does not have the internet protocol feature activated.

The internet protocol feature has to be enabled by wavecom (or your distributor) before the WIP library will operate correctly. See this post for some hints on checking if the Internet Protocol feature has been enabled on your modem.

If Internet Protocol feature is NOT enabled on your modem, all you can do is go back to your distributor and talk to them about getting it enabled. It will probably cost you some money though - as the Internet Protocol feature is an added extra (as is CGPS, RTOS, Watchdog etc).

Please let us know how yoyu get on.

ciao, Dave


#3

You can use the basic WIP TCP and UDP sockets, but the internet protocol feature is required in order to use higher-level protocols like HTTP, FTP, etc…


#4

you can always write your own functions ofcource…


#5

Absolutely!

You could start here for some ideas: curl.haxx.se/libcurl/competitors.html


#6

Hiya,

Is this correct? It was my understanding that only the GPRS functions available from OpenAT (i.e. adl_gprsXXXX() API functions) were available if the Internet Feature was not enabled.

Although - looking at the traces above, it appears that the WIP network connection has operated correctly …

ciao, Dave


#7

Well, that is certainly my understanding of the situation.

That was the advice from my Distributor, and I did a project recently on that basis: the application just used WIP UDP sockets so that the client could buy devices without the Internet Feature enabled.

Exactly! 8)