Upgrate FSU firmware from 6.63 to 7.3


#1

Hi, all.
I have a Fastrack Supreme modem that runs firmware v. 6.63. I tried to upgrade firmware to the one contained in Open AT SDK 2.20 (v7.3), but every time I try I get “ERROR IN HEADER” message. As far as I understand, I can not upgrade from 6.63 to 7.3 directly and have to install a couple of intermediate legacy versions. Can someone tell me which exact versions I have to install and where do I get legacy firmware packages? I couldn’t find them in the “downloads” section for Fastrack Sumpreme.
I also tried to flash FSU with DWL Win, as it is described in Firmware 7.3 release notes, but DWL reported me the following error message:

Thanks in advance.


#2

Hey

I have the same problem. I always get “error in header”.

I am using hyperterminal now, where did you get DWL Win, can you give me a link from where I can get it?

And can some one help us upgrade our modems?

Thanks


#3

Hiya,

You can’t upgrade from 6.63 to 7.3 firmware using the firmware files supplied in the OpenAT 2.20 distribution. These files are ONLY for upgrading from an earlier R7xx version to R7.3 using the XMODEM download method. There are a large number of internal changes between R6xx and R7xx firmware - including the downloader and bootloader code - which is why the XMODEM method won’t work.

You will need to download the appropriate .wpk (probably R7.3_00-cus-Q26-01.wpk for the Fastrack Supreme) file for your device from the Wavecom Developers site. This file can then be used with DWLWin to reflash your module.

Done this a number of times - works well for me.

Don’t forget that you will have to recompile ALL your applications using OpenAT 2.20 for them to work under R7.3 firmware.

ciao, Dave


#4

I have downloaded R7.3_00-cus-Q26-01.wpk and couldn’t flash it with DWL Win either. To upgrade firmware I had to ground boot pin of FSU’s Q26, power on the modem and flash 7.3 fw using DWL Win.


#5

Hiya,

Yep, you will definately have to short the BOOT pin to ground to get DWLWin to connect to the modem.

There’s plenty of other posts on the forum about that (and on upgrading the firmware).

ciao, Dave


#6

Thanks!!

I did it!

My problem was not finding the documentation in wavecom’s site. It is really tricky. I found the archives link in downloads tab really late, I was desperate already.

The documentation about firmware release R73 says you need to have already loaded in the fastrack version 7.2, and that is not true! I went directly from 663 to 73.

My other problem was my usb to serial cable was not working fine. I had to use another computer with a serial conector.

It would be really helpfull to have all these tips in a pdf!

Anyways, I could do it thanks to the forum.

Thanks


#7

Hiya,

Glad you got everything to work - and that the forum was of some assistance to you.

This is true if you want to use the XMODEM upload (or DOTA) methods. DWLWin can get into the firmware on the modem at a much lower level than the XMODEM downloader.

Yep - are you offering to do it? Someone who’s just had to fight their way through the process is probably the best person to write it up…

ciao, Dave


#8

Yes you are right, I should write a doc about this! But wavecom is a private corp! this is not like wikipedia where you help for free!

Anyways, now that I think so I should do it anyway, now that Obama is making the US a socialist country, I am a little confused where private ends and public starts!!!

I volunteer…


#9

Is there a specific reason why all fastrack supremes are shipped with older 6.63 firmware while the latest versions are 7.3. I am experiencing exactly the same issue. Can someone please explain or point me to docs that explain the procedure how to “short the boot pin to ground”.

Thanks
Yash


#10

I did it with this post.
viewtopic.php?f=53&t=3040&p=11191&hilit=boot+pin#p11191

You need to change the cable to ground the boot pin, you need the software DWLwin. Be sure to plug the modem miliseconds after you press the start button.


#11

That was the way for the old Fastrack M1306B - just grounding the boot pin does not work for the Supreme.

The Supreme documentation suggests that you need to apply 1.8V - but it is unclear.

Others on this forum claim to have had success by connecting a 10k resistor to ground.

Because of all the doubt & uncertainty, I just let my Distributor do it. 8)

Alternatively, use the RESET pin…


#12

you must have a good distributor then, mine takes a week just to answer an email…

I grounded the boot pin using a 10k resistor, it worked perfect


#13

OK thanks. I am doing a project out of my home. So I do not have the right tools. I have contacted the distributor and they mentioned they are trying to make a special cable for me. They are also contacting Wavecomm for details as to why the modem I have has FW 663 and the SW suite shipped to me has installed FW V7.2 on my PC and the website shows a latest V7.3. Big mix up :slight_smile: Looks like I cant even downgrade Sw suite to support older FW. So pretty much I am stuck not even able to run hello-world program.

Yash


#14

Hi, i do such thing in this way: (just two step , used only Hyperterminal, standart cable)

  • uploaded dwl_port.dwl ( to upgrade loader)
  • uploaded R73_00_full_fsu001.dwl (from OpenAT SDK)

#15

Crosspost:

I cannot get pass “starting up the target” message.

What is the exact procedure?

I’ve tried:

  1. Ground the pin with 10k res while the fasstrack is off.

  2. Remove the res.

  3. Connect the power.

  4. connect the serial.

  5. Ground the pin with 10k res while the fasstrack is off.

  6. Connect the power.

  7. Remove the res.

  8. connect the serial.

  9. Ground the pin with 10k res while the fasstrack is off.

  10. Remove the res.

  11. connect the serial.

  12. Connect the power.

I also tried sever combinations with grounding the pin when the fasstrack is on. In every case the Dwlwin was running and start button was pressed before the procedure. I’ve used ground wire of the AC/DC stabilizer for grounding.

Thank you for your help.


#16

Hiya,

Check out this post viewtopic.php?f=53&t=1907&p=11665 about making the approriate cable.

Then a couple of posts earlier viewtopic.php?f=53&t=1907&p=11665there are the exact instructions on connecting to a Fastrack Supreme using DWLWin. Note specifically steps 8, 9 & 10.

Ignore step 5 - you really do want to check the correct firmware file to download to the modem.

Let us know how you get on.

ciao, Dave


#17

tsarapin

What is dwl_port.dwl? where did you find it. Do we need to upload that file before upgrading?

Thanks
Yash


#18

Making a boot cable solved the problem. Thank you! I’ve followed all the steps except 7. Set Wireless CPU Type to AutoDetect. This hasn’t worked, I had to choose module manually. (Fastrack Supreme)


#19

Hiya,

No problems. Glad that you got everything to work.

ciao, Dave


#20

A migration procedure from Firmware v6.63 to Firmware v7.x (Open AT Software Suite 2.xx) with X-modem download is available on http://www.wavecom.com/modules/movie/scenes/developers/index.php?fuseAction=articleNoRight&rubric=developers_releaseNotesLinks&article=developers_RN_upgrade_Xmodem