Upgrading from R71a01 to R73


#1

Hello,

I have recently downloaded the latest SDK files and in which I have the DWL file to upgrade the fastrack supreme 20 modem I have. In the release notes it refers to a migration document “WM_DEV_WUP_MEM_022” does anyone know where I will find such a file?

Alternitavly, as I am running R71a01 would this be defined as ‘older’ than R71 - because in the Release Note it gives the following warning

  WARNING: If the original firmware is older than R71, it is mandatory to follow the instructions of the document describing how to migrate to R72 before
   downloading the dwl files provided for the FW R73 [15]. Otherwise an error message occurs concerning a bad header format.

If it is NOT older than R71 (as it is R71) am I ok to do a straight upgrade to R73??

Many thanks
Neil


#2

OK…

After much searching a post was found regarding this at the following place:
http://www.wavecom.com/modules/movie/scenes/forums/viewtopic.php?f=53&t=2518

Basically

  1. ground the boot pin on the 15 way connector on the modem using a 10Kr resistor (the chassis of the modem is ground, so this would be a ‘convenient’ place to link to)

  2. Upgrade to firmware “R72a00-cus-q26-01.wpk” this file can be located through the wavecom website - goto the plug and play section, then select the Supreme modem, goto the downloads tab at the top, then click the little archieve link - this takes you to all the old archieves. If you click on the folders /Open AT Software Suite/Software development kit/Official Realease you will fine it in here.

  3. Upload the firmware using DWLWIN - this can be a little tricky - the trick is to have DWLWIN set before you are ready to go. Click the START button, then power on the modem fractions of a second later. You will see a green bar fill up - the whold process takes a few minutes.

  4. Once the firmware is updated you should switch off, and check it is OK using hyperterminal.

  5. No you need to do the firmware to R73 - this is found in the current downloads section. Follw the steps as above!

Happy modeming!


#3

There is a great deal of confusion about this part! :confused:

The old M1306B - the Supreme’s predecessor - did require that you ground its BOOT pin.

But the Supreme documentation (the User Guide and the “Deltas” document) specifically states that it is different in this respect - and requires 1.8V to be applied.

Grounding the BOOT pin certainly didn’t work for me when I tried it on an early Supreme:angry:

Maybe there’s just some kind of timeout after startup during which the Supreme will respond to DWLWin irrespective of the state of the BOOT pin… :question:


#4

with the Q2686(h) i was able to see the state of the boot pin in hyperterminal.
then the boot pin was enabled, my modem printed 3 unusual characters starting up after power-down or reset.
but i cant confirm if it does that only with firmware R72 or also with other firmware versions.


#5

So, what is it that “enables” the BOOT pin :question:

Is it:

  • Grounding it - as the OP suggests (as the M1306B did it), or
  • Applying +1.8V - as the documentation suggests.

#6

Based on the information located at thread - http://www.wavecom.com/modules/movie/scenes/forums/viewtopic.php?f=53&t=2518
The user there said that they tried to take the pin to 1.8v as the manual suggests and that didnt work, so they got intouch with the distributer, and they got back to them and said to try to ground the pin with a 10Kr - This worked.

I had done this operation a few times now, and it works every thime - however in the DWLWIN software it didnt work for me using the ‘auto detect’ setting I had to use Q2686/Q2687

Hope this helps


#7

There is a way to do this without needing DWLWin neither using the bootpin. Tell me if the problem is still pending for you


#8

I cannot get pass “starting up the target” message.

What is the exact procedure?

I’ve tried:

  1. Ground the pin with 10k res while the fasstrack is off.

  2. Remove the res.

  3. Connect the power.

  4. connect the serial.

  5. Ground the pin with 10k res while the fasstrack is off.

  6. Connect the power.

  7. Remove the res.

  8. connect the serial.

  9. Ground the pin with 10k res while the fasstrack is off.

  10. Remove the res.

  11. connect the serial.

  12. Connect the power.

I also tried sever combinations with grounding the pin when the fasstrack is on. In every case the Dwlwin was running and start button was pressed before the procedure. I’ve used ground wire of the AC/DC stabilizer for grounding.

Thank you for your help.


#9

viewtopic.php?f=53&t=2518


#10

I know this is a long time after the topic, but I’m a new user and I read the document about the delta to the Supreme as saying that the M1306B runs at 2.8V internally and the Supreme at 1.8V without actually saying that these voltages cause anything in particular to happen.
This is a warning that if you were driving the BOOT or RESET pins of an M1306B with a logic signal at 2.8V, rather than just pulling it to ground or letting it float, then you might fry a Supreme if you drove 2.8V into it!

As other posters say, pulling the BOOT pin low causes the Supreme to enter boot mode briefly before starting normal operation, so the way to do an upgrade is to start DWLWin first and then power-up the Supreme.
A few measurements with a multi-meter show that BOOT is pulled up to 1.8V by an effective resistance of around 68k-ohms. 10k to ground pulls this down to 0.228V which is probably OK for 1.8V logic. Pulling BOOT directly to ground causes 27micro-amps to flow :slight_smile: