Upgrade firmware from commandline on linux


#1

Hello,

I need to upgrade firmware of a set of fastrack xtend, supreme, from a remote linux host.
Which file I need to download? And how should be downloaded?

I tried to use R7.47.0_fsu004.dwl and dwl.dwl.
I uploaded with following:

  • AT+WDWL
  • sent file via xmodem
  • AT+CFUN=1

but now the the red led is not flashing anymore (sim is inserted, door locked, …)

any suggestion?


#2

Hi,

Can you explain how are you trying to upgrade from remote linux host?

The files that you need download are given below and in the same order:

  1. dwl.dwl
  2. R7.47.0_fsu004.dwl
  3. w.dwl

Regards,
Paruthiv


#3

connected via ssh to the remote linux host
used a perl script with Modem and XModem modules that downloads a given dwl to the modem.
the perl script performs

  • AT+WDWL
  • send file via xmodem
  • AT+CFUN=1

I uploaded the following files:

  1. R7.47.0_fsu004.dwl
  2. dwl.dwl

Now I downloaded all the files you suggested in the correct sequence, but the led still not blinks.
The modem answers to at commands such ati9 but not tries to register to the network.
I tried the sim on another fastrack and it works.
Should I use a windows tool for try to reset completely the fastrack?


#4

Hi,

What is ATI3 reports and what is the model of your Fastrack.

While Fastrack will accept firmware destined for different unit (you can load FXT009 version into FXT003 for example), symptoms will be exactly as you describe – no registration, but AT interface works.

Firmware you are loading must match the unit hardware!

Rudolf


#5

Hi,
here the modem answers:

ati3
R7.47.0.201202010317.FSU004 2221420 020112 03:17

ati9
“DWL”,“V08b13”,"",“Sierra Wireless”,55344,“111611 18:03”,“dda36757”,“00010000”
“FW”,“FW_SRC_747_8.Q2687G”,“R7.47.0.201202010317.FSU004”,“Sierra Wireless”,2221420,“020112 03:17”,“31be8644”,“00020000”
“OAT”,“1.1.9”,“watchdog”,“Wuerth Phoenix S.r.l.”,83008,“031212 15:30”,“0aca71da”,“00260000”
-“Developer Studio”,“2.1.1.201201180944-R8656”
-“Open AT Framework package”,“2.37.0.201202280640”
-“Open AT OS Package”,“6.37.0.201202060950”
-“Firmware Package”,“7.47.0.201202010317”
“ROM”,“800000”
“RAM”,“200000”
“DWLNAME”,“FSU004”

many thanks


#6

i see: the firmware should be the one for FXT009 !?


#7

I found that with ati0 I can get the modem version.
now I uploaded the correct firmware and the modem works again

thanks to all for the help!