Turning off GSM stack from OpenAt


#1

I’m having some problems turning off the GSM stack from OpenAT.
According to the AT commandset, I need to send either AT+CFUN=0 or
AT+CPOF to turn off the GSM stack (for powersaving), and then AT+CFUN=1
to turn it back on.

I use the following API call to turn off the stack:
adl_atCmdCreate("\rAT+CFUN=0\r", FALSE, myHandler ,"*", NULL);

But I get an adl_atResponse_t with type ADL_STR_ERROR. Have I overlooked
anything? I can turn off the GSM stack over rs232 fine with AT+CFUN=0,
but just not from OpenAt. Any hints?


#2

Two things I found out:
1: The ON/OFF input was in the wrong position
2: There shouldn’t be any \r around the command.

Now it appears to work.


#3

OK - I’ve gotten a little further now. I can turn off the GSM stack with AT+CPOF from OpenAt, and that works as it should.

Now, the documentation says to turn the stack back on with a AT+CFUN=1, which I’ve tried. But that resets the module, and restarts the OpenAt application as well. Is there no way to restart just the GSM stack, and let the OpenAt program continue running?

I’ve also tried AT+COPS=0, but that gives +CME ERROR: 3


#4

No, You have no other way, unless restart the module with “AT+CFUN=1”.


#5

Did anyone tried to use the “AT+WREGC” command to register/deregsiter from GSM/GPRS.
Does it effect the radio functinalities (on and off)?


#6

(my emphasis)

So the radio functionalities must still be running.