Incorrect +CREG:2 after AT+CFUN=0?


#1

I removed the SIM, then issued AT+CFUN=0 to stop the GSM stack:

Then I replaced the SIM:

+CREG: 2 means that the unit is searching for the network - but that can’t be true, as the GSM stack is stopped (AT+CFUN=0) :exclamation: :open_mouth: :question:

So what’s going on here, then?!


#2

:astonished: … Are you really sure …?? i actually tried it on my module but it was working fine here( means no +CREG :2 indication ) …
Tell me are you using ne Open AT Application as well…?? Is this scenario happening with a particular firmware or module?
or is it everytime…?? :question:


#3

Yes:

  • I’m sure that the AT Commands manual says that +CREG: 2 means that the unit is searching for the network;
  • I’m sure that the AT Commands manual says that AT+CFUN=0 stops the GSM stack;
  • I’m sure that is the trace that I copied & pasted from the Terminal Emulator window

I just tried it again on a Fastrack Supreme:

at+cgmr
663_09gg.FSU002 1955080 080207 16:01

OK

at+cfun=0           <-- Stop GSM Stack
OK

+WIND: 8            <-- Network lost (as expected)

+CREG: 0            <-- Not registered; not searching (as expected)

at+wopen=7
+WOPEN: 7,0         <-- App loaded, but not running

OK

+WIND: 14           <-- SIM removed

+WIND: 13           <-- SIM replaced

+WIND: 14           <-- SIM removed

+WIND: 13           <-- SIM replaced

So it must’ve been a particular unit - now, which one was it…? :confused:


#4

:smiley: … yah i thought so… So this means it is a module problem only… so what are you planning to do…??
btw did it have the same firmware…?? i wonder if the same thing wud be repeated if we erase the flash, reload the firmware in dat particular module and den again give it a shot… what say…?? :question:


#5

Not necessarily - it could (also) be a firmware issue…

I’ll have to try and remember which unit it was - and confirm the behaviour!

Almost certainly not…


#6

hmmm… then it could be a F/w problem… but it wud be gud to test it once… and may be erasing flash n again downloading the f/w wud help…
will hv to wait till u find the naughty module… :laughing: