Network Registeration


#1

Hi,

I work on Q2687 module ,I succeded to make TCP connection but I have a problem with +CREG
the problem as follow:
1- I run my code and TCP connection is establised.
2- when the network is disconnected, I check AT+CREG? and I found the value +CREG: 0,0
3- the module is stuk at this value and I should reset the module to register to network agin

in berif, when the network disappears for litte time and comeback the value of CREG stuk at 0
and doesn’t back to 1 even network back and I need to reset the module

thanks and waiting your reply,


#2

Are you using AT commands from an external processor, or is it an Open-AT Application?


#3

Try monitoring CGREG responses for your network status.
Also check your CREG mode, the default is no unsolicited result code.


#4

I used openAT Application
CGREG also 0,0 when CREG =0,0

Is there any way to force the module to make manual registration using AT cmd or APIs


#5

What does AT+COPS? tell you?

Do you get the same problem without the Open-AT application?

ie, is it something inherent in your setup, or is it being caused by the Open-AT application?


#6

That is to be expected, as GPRS is an “overlay” on top of GSM.

Therefore, you can’t have GPRS registration (CGREG) without GSM registration (CREG) - can you :question:


#7

at+cops return ERROR when CREG=0,0

I stopped my application and do the following steps:
1- check CREG and result is 0,1
2- remove antenna and wait until CREG goes to 0,0
3- re-connect the antenna and wait CREG to be 0,1 but CREG stuck at 0,0

my result that the module doesn’t register again after the network disconnected although the network signal is comeback
when I restart the module it works well but if network disappears again, the problem appears again

I need a way to re-register to the network when CREG stuck at 0,0


#8

at+cops will always return ERROR - because it is not a valid command!

The command you require - the one that I suggested - is at+cops?

Note that the ‘?’ on the end is important!


#9

I mean at+cops? return ERROR when CREG: 0,0


#10

With the SIM removed, I get the following with signal:

or the following with no signal:

Looks like there’s something wrong with your kit!

You should contact your Distributor - they should be able to talk you through on the phone, and should be aware of any local issues…


#11

many thanks for all

I will check it with the distributor


#12

That sounds weird. I had problems with the +creg command before, and after a firmware reload it was fixed, maybe try reload the current firmware, or a new firmware.


#13

One of the things that a “firmware reload” does is to resore all settings to defaults.

So, if a “firmware reload” fixed it, that could well mean that you’d messed-up some settings…

eg, is the Frequency Band selection correct?


#14

That’s strange!!

The Open AT OS should handle the network registration by itself.
The only limitation here is that it depends on the +wind unsolicited responses.

Do you by any mean disable the unsolicited +wind responses in your application (AT+wind=0) ?

If yes this could be the problem.
Note: You can test it by “AT+wind?”


#15

Is there any news?
Have you tried anything?
Please share your experience. Don’t only take what you want from the forum then stop posting your trials or this forum will die.

That’s what forums are for.


#16

Excellent point!

:smiley:


#17

Sorry I thought that this discussion closed when awneil told me to ask the distributor.

My current solution is timer rises every 5 sec to check the existence of GPRS attachment.
If GATT returns 0 then send at+cfun=1

I know this bad solution but this is fast solution.

I found something may be responsible for my problem in this link
https://forum.sierrawireless.com/viewtopic.php?f=107&t=5266&start=0
because our production line erased customization files on the module.

thanks to awnil because he guides me that I have something wrong on my kit


#18

Did it solve the problem? because I don’t think this has any relation. Erasing customization files SHOULD not affect network registration.

Have you checked the +wind unsolicited responses? “AT+WIND?”

Also you can check this post:
[url]https://forum.sierrawireless.com/t/disabling-wind-notification/4849/1]


#19

Try AT+WMBS?

This will tell you what frequency band you are on. Make sure you use the right one for your location.

I also assume SIM card is OK. Try your SIM card in your mobile phone just in case.

Rudolf


#20

Try reseting the PLMN search by issuing AT+COPS=0 and see if it helps.