GSM network problem


#1

Hi,
i will try to describe the problem basicly

  1. It disconnects from GPRS after some passive time.
  2. After some more time, we can not reach the modem by CALL (Even by mobile phone->Operator says the number you called can not be reached at the moment… ).
  3. But when we look our logs, it shows that AT+CREG? responses returns “1” for “stat” parameter which tells modem is still registered to GSM network. Even modem’s led is still blinking.
  4. After hard reset, modem connects to GPRS and we can now reach the modem by CALL.

I think modem loses the GSM registration but it can not detect it. This happens on some modems which are on the area so i can not get any traces. What can cause this problem?

Thanks


#2

What disconnects?

How does it “disconnect”?

Can you try issuing AT+COPS=0 in this condition?
See: https://forum.sierrawireless.com/t/undocumented-side-effect-of-at-cops-0/4871/1


#3

Hi Awneil,
Do you think that modem gets stuck in “Emergency Calls Only” mode? And AT+COPS=0 will reset the PLMN search and will allow the module to escape from stuck?
I will try to apply AT+COPS=0 in my application. Should i set a timer which executes AT+COPS=0 in every 24 hours? Or is there a better method to discover stuck state and escaping from it?

Thank you.


#4

Not if you are correct that AT+CREG? returns “1” for “stat” - ie, the unit is registered on its Home network.

Can you speak to technical staff at the network operator about this?

Or your Distributor or FAE - it might be a known “feature” of your local network(s)…

As noted in the link I gave, it does seem that AT+COPS=0 does more than is documented, and does allow an escape from some “anomolous” registration conditions.

I haven’t seen the condition you describe, so I don’t know whether AT+COPS=0 will help in your particular case or not - you will have to try it yourself to see what happens!

Great - please post the results!

Again, this behaviour of AT+COPS=0 is undocumented - so who knows whether there might be any problems in doing this…?

If AT+CREG? is, effectively, lying to you, then I don’t think that there’s a lot you can do!

Unless there is some other feature of your application that you can use; eg, * is GPRS affected?

  • Do AT+CSQ or AT+CCED or any others give any useful hints?
  • Can the unit send and/or receive SMS in this state?
  • Does your application expect some regular incoming contact, and can it use that as the basis for a timeout to deduce that it has lost comms…?

#5

Hi Awneil,
-Our customer says that modem is still blinking when it happens.
-Our logs says AT+CREG? responses “stat” as “1”(registered home network).
-We can not call the modem, operator message says “The number you’ve called can not be reached at the moment…”
-Modem can not receive SMS in this state. I havent tried sending SMS.
-It is not releated with GPRS because it always happens after GPRS disconnection WIP_BEV_IP_DISCONNECTED.(My application does not reconnect to GPRS When it disconnects)
-My application executes AT+CSQ only after GPRS disconnection and the response is +CSQ: 16,X.

Modem seems to be unregistered from the home network but AT+CREG? says it is registered.

I will spend more time to investigate the problem. The problem happens for period of 2 days. I will contact with distubutor and i will try to contact with GSM operator and i will test AT+COPS=0. If i will get a solution i will write here.

Thank you.


#6

That should indicate that the modem is registered (or, at least, that it thinks it is registered);
if it were in the WIND: 7 “stuck” state, the LED would be steady.

Indeed - the modem thinks that it is registered…

… but the network thinks that it is not registered!

If you enable delivery receipts, does the network think that the SMS has been delivered?

I mean, can you reconnect to GPRS once this has happened?

If so, does reconnecting to GPRS also restore the GSM registration?


#7

I havent tried it. But once it happens again i will check it.

I havent tried reconnecting GPRS but in the past, i often transfer data from the modem to keep GPRS connected. When it stay connected, this problem never happened. So this shows the problem occurs after GPRS disconnection.


#8

What causes the GPRS disconnection?


#9

The error code is -36 (WIP_BERR_GPRS_FAILED -> Gprs set up failure). Explanation of the error code is poor for our problem. But other modems receive the same code when disconnecting from GPRS. Also we know that GSM operators disconnects you from GPRS after a few hours if you do not transfer any data. So we can say it seems normal.


#10

Ah: so it’s network-initiated - not your application initiating the disconnection?

In fact, the explanation is completely wrong - it has nothing to do with set up!!

:angry:

See also: https://forum.sierrawireless.com/t/wip-berr-gprs-failed/2544/1

Over here, they don’t tend to disconnect you from GPRS, but they time-out your session at the APN - leaving GPRS connected.
This is a pain, because there is no way for the unit to tell that it’s happened!