Problem about network registration


#1

Hi,
I have problems sometimes about gsm network registration. AT+CREG? command returns +CREG: 0,2 that means “not registered, ME currently searching for a new operator”.

But there is enough signal strength which is about +CSQ: 11,99. My open AT application resets the modem with AT+CFUN=1 on every 2 minutes if network registration fails. But it can not solve the problem. When modem is reset, it still can not register. I even powered off the modem, then powered on again but it didnt help.

How can i get more information about this behaviour?


#2

Are you sure that there is any service available on any network that the SIM is allowed to use?

This can happen when there is no (usable) service from the SIM’s “Home” operator, and the SIM is unable to roam to any of the available operators.

In this case, the module will register for “Emergency Calls Only” (WIND7) to one of the “foreign” networks - and the CSQ reading will relate to that network.

I think 2 minutes is too short a timeout here - try 15.

But, if there is simply no usable service available, then there’s nothing you can do to force the software to use a service that isn’t there!

Your only options are:

  • Try a high-gain antenna to increase the required network’s signal to a usable level;
  • Change SIM to one that allows access to one of the available networks;
  • Reposition the unit to somewhere that service is available.

#3

For example:

Roaming is not allowed between the national networks in the UK.

So if you have, say, an Orange SIM where there is no Orange service, but O2 service is available, the Unit will be able to register to O2 for “Emergency Calls Only” - but nothing else.
In this situation, the result of AT+CSQ will relate to the O2 signal.


#4

Hi awneil,

The modems were on the same desktop. There were 5 modems (Supreme 20 R7.1b) and all of them have the problem. Note that modems were working OK up to now.

I moved one of them to my desktop where i can be sure of signal quality and operator coverage. But the problem remained. I changed the SIM card to a new one (same operator) and still same problem. I also download the open at software again but it didnt help.

Finally, i used Supreme 20 663g firmware with the same SIM card and same open at application which is built on 663g firmware. And it worked!! That shows my supreme products that has R71b firmware has a problem? If so is there anything i can try to apply for a solution before i will go to my distrubutor?

Thank you very much


#5

Hi

I picked up a funny network registration problem with a fastrack supreme today, hope you don’t mind me posting in your thread.

The network indication LED starts blinking a few seconds after startup but at+creg? returns 0,0. The problem is not with the SIM and network reception. I though it might be some setting on the module, but I went through all the network registration AT commands and tried at&f but it keeps doing it. The module won’t register to the network but the LED keeps on flashing.

The problem happens with and without an OpenAT app running, and only with this one module.

I.t.o your problem, does the fastracks register to the network without the OpenAT app running?

Thx


#6

Hi,

The modems can not register to network while open at is not running neither. But i understand the problem. It is not about open at software, firmware or something. It is about Imei registration rules in our country. You must register your imei number in our country within 2 weeks. There were 2 weeks after i started my modems. So sim operator blocked my imei number and prevent it to connect gsm.

i hate problems which is not related to software. But this will always exist.


#7

There is a known issue in OpenAT where modem can not register. DSP gets into some funny state. Reset should help, however.
Was observed on R71, R73. Was partially fixed in R74 and almost non-existent in R74a.
We have registration timeout set to 4 minutes. If no registration was achieved, modem resets.

Rudolf Ladyzhenskii
SymStream


#8

I can confirm this issue with R73. Sometimes the modem would just not register on GSM again. We have not seen this issue with R7.4.3 at all.


#9

I am using R7.4.3 but I seem to be experiencing the registration problem when coming out of low power mode. The on/off input is toggled low and AT+CPOF command is sent to the modem which powers down but when the on/off input is toggled high, the modem does not seem to register with the network. Anyone seen this problem before.


#10

Found out the problem was caused by a dodgy ground in the car that was causing the problem.