Network Registration


#1

Sorry if this is a begginner question, but I cant seem to get this dev kit to obtain service.

Does the module automatically get service on boot up?

at+csq is always 99,99

creg is always 1,0

The antenna is connected, and I know the sim is working because it is able to get service on a modem.

Is there some special procedure to make this thing register?


#2

Hiya,

Do you have a pin enabled on your SIM card? Network registration does not happen until the SIM module is ready.

Check if the sim is waiting for a pin code by using

AT+CPIN?

This should return

AT+CPIN: READY

if the SIM module is ready. Check out the doco for what the other error messages mean.

The SIM card is not ‘Locked’ to the phone? (i.e. some pre-paid accounts lock the sim to the phone and the network). If so, you’ll have to get an unlocked SIM…

Also turn on extended errors using

AT+CMEE=1

This will give you error numbers that can be looked up in the AT command doco, rather than just ‘ERROR’.

Also, the type and location of your antenna can make a difference to how long it takes for the module to register with the network.
ciao, Dave


#3

You mean AT+CREG? always returns +CREG: 1, 0 :question:

The response format is +CREG: ,
=1 means +CREG: unsolicited responses are enabled;
=0 means “not registered; not searching”

What other unsolicited +CREG: responses do you get after re-starting the module?

What does AT+COPS? return?


#4

On powerup, I will do:

at+creg?
+CREG: 0,0

OK
at+cops?
+COPS: 0

OK

I will then do:

at+creg=1
OK
at+creg?
+CREG: 1,0


at+cops?
+COPS: 0

OK

at+cops=0
+CME ERROR: 529

This is for “PLMN selection failure, emergency calls only”

Do you think there is some hardware issue and it was just a defective dev board?

I can use the same sim, and antenna on a Siemens board and can achieve registration, but this board with the wavecom seems to never try to even register.


#5

try:

AT+WIND=32767     -- enable all WIND indications

AT+CREG=2         -- enable unsolicited CREG responses

AT&W              -- save settings

AT+CFUN=1         -- restart the module

Then you should get a series of unsolicited responses to show you what’s happening as the unit starts…

Also try AT+COPS=? to get the list of available networks (note that this can take 30s or so to respond).

Is your DevKit properly configured with a valid IMEI that your operator will accept?


#6

I’ve done the following:

at+wind=32767
OK
at+creg=2
OK
at&w
OK
at+cfun=1
OK

+WIND: 3

+WIND: 13

+CREG: 0

+WIND: 1

+WIND: 16

+WIND: 4

+WIND: 10,"SM",0,"FD",0,"ON",0,"EN",0

+WIND: 11,,,,,"28C8868A4315E73F16BAF5766F4155A4","30F5634B16FDC71A605D42F1F384420C"

It seems to just not connect.

after trying “at+cops=?” the unit responds with : +CME ERROR: 30, “no network service”

I’m not sure about the IMEI configuration. I will try to see where I can set that value.


#7

if the imei value is not something like 1234567… etc… it should be acceptable for your provider.


#8

That means the unit is not registered, and is not trying to register.

Is the unit correctly configured for the available frequency bands in your area?

I think you should be talking to your Distributor about this - they should be able to talk you through the sequence, and diagnose any problems. They might even be able to pay you a visit.
[/quote]
I’m not sure about the IMEI configuration. I will try to see where I can set that value.
[/quote]
The IMEI is supposed to be globally unique - no two GSM devices anywhere in the world should ever have the same IMEI.
Never.
Period.

Hence you should not be able to set the IMEI!
But I gather that some DevKits may be delivered with a “default” or “dummy” IMEI - and some networks may refuse to recognise such a device.
Again, check with your Distributor


#9

Be sure to do a AT+CPIN?

At one stage I had the problem that the logic for the SIM detect pin was inverted so that the Wavecom CPU didn’t detect that I had inserted the SIM. If this is the case, you can do a at+wfm=0,7 to turn off the SIM detection feature. (at+wfm=1,7 turns it back on)

The “No Network Service” suggests you are getting no signal - maybe your antenna is faulty.


#10

No, it’s not that:

+WIND: 1

+WIND: 10,“SM”,0,“FD”,0,“ON”,0,“EN”,0

+WIND: 11,“28C8868A4315E73F16BAF5766F4155A4”,“30F5634B16FDC71A605D42F1F384420C”

all indicate that the SIM is present & correct.


#11

I found the problem. The default setting for the Band was not set to USA.


#12

How do you change the Band ?


#13

You could start by searching in the AT Commands Guide for “band”


#14

I found it I was looking in the wrong document.

AT+WMBS

my bad.

Thanks again