Trying to connect FX30 to ubuntu 18.04 VM/what drivers for linux

#1

Hi I am trying to connect through my USB to the fx30 for the first time. I am running a VM with Ubuntu downloaded from the mangOH website.
I was able to get the linux Network manager to add usb0 which is the fx30 usb connection but it won’t assign it an ip address. I am using Virtual Box 6 and have cable connected ticked under NAT network type. I also have the usb device added as a filter.

I think my driver is wrong I have a qmi_wwan driver which I think is correct but I’m not sure how I got it. I tried to update the driver using a QMI driver I downloaded from the Sierra Wireless source but when I unzipped it I got GobiSerial GobiNet directories with make files in them and it looked wrong. (what is this?)

Here is the usb-devices drivers
T: Bus=01 Lev=01 Prnt=01 Port=01 Cnt=02 Dev#= 4 Spd=12 MxCh= 0
D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=1199 ProdID=68c0 Rev=03.18
S: Manufacturer=Sierra Wireless, Incorporated
S: Product=Sierra Wireless FX30(WP7702)
S: SerialNumber=VU83838515121017
C: #Ifs= 6 Cfg#= 1 Atr=a0 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=qcserial
I: If#=13 Alt= 0 #EPs= 1 Cls=02(commc) Sub=06 Prot=00 Driver=cdc_ether
I: If#= 2 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=qcserial
I: If#=14 Alt= 1 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_ether
I: If#= 3 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=qcserial
I: If#= 8 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=qmi_wwan

Anyone have any Ideas and which linux driver is the correct one for the fx30 ?

…Tried to install the GobiSerial/GobiNet but the GobiNet one failed I’m not sure if they are the correct ones

#2

I updated my windows wp77 driver and added a virtual box extension one of the two fixed the VM issue thanks