Trouble with a GX440

Hello all. I am having trouble with an AirLink GX440 and I’m hoping someone can provide a little insight. When I start it up everything goes through the red-green-yellow cycle. After they have all cycled only the power light stays green. About 30 seconds later the network led starts to slowly flash yellow and the signal led begins to flash red even slower. I have tried using a different antenna with it that I know is good and still no change. Is there something I’m overlooking? Any ideas and suggestions are appreciated. Thanks.



Have you got a sim card in the unit?

Does the SIM card have data services provisioned?

Is the APN etc set up properly in the unit?

There are some logging facilities in the web interface - can you see anything of interest there?

ciao, Dave

I’m having this same issue. Any information is appreciated. I have two units down and what appears to be stuck in a boot cycle.

After boot completes the Network and Signal led will blink for a few seconds and the device will then reboot itself.

Update: I pulled the MC7750 aircard radio from the modem and that stopped the reboot issue. I can now login to the admin panel and have applied ACEmanager update to 4.4.4. However I cannot get it to update the radio firmware.

We have had a number of GX440s display this same action. What we were told (as our failure rate was on the order of 25%) is that the radio module either failed, or the comms between the RM and main board were not working. The fix was to have them sent in under warranty and in most cases replacement of the MC7750 radio module fixed it.

We have many hundreds of GX440s, and all of them are now running 4.4.4 FW. There was a time (Pre-4.3.6 FW) that would cause a condition where the radio code would become corrupted, and required replacement. We still periodically have them in the field die, displaying your same symptom. We send it back, it gets a replacement radio module, and it works again.

Needless to say, we’ve been none too thrilled with this. However, we are deeply invested in these (500+ and counting) and are now on the GX450. I haven’t experienced the same failures with the GX450 yet, so only time will tell.

None too happy to report our findings, but this does correspond well with our experiences.