*SOLVED* EM7455 unable to enable

Hello All,

Debian Bullseye
pcie X1 to M.2 adapter

New to Sierra Wireless cards.
After many hours of learning ,struggling with a Sierra Wireless EM7455 a couple days ago,was able to very momentarily make a connection to Operator with an activated Visible sim card. Would only connect for 10 seconds. The syslog really never could devlage what was causing this. This is a connection setup through NetworkManager gui.
Was using the latest generic rom image. After many hours trying to get good connection decided to flash to the Verizon image. Then am getting 'not enabled,and clicking the enable button in NM gui nothing happens
tried doing many many 'simple connect 'examples from terminal found in Google none worked
Have learned many ,many AT commands to try,and none seem to remedy the ‘not enabled’ problem.
One thing I noticed doing an mmcli -m 0,in the info modem is in low power mode. Cant remember if this was showing when i was able to get a connection.
Can anyone give any insight were i should look for clues?


What is the response of the followings?


What is the previous image it used before flashing verizon image?

Hi jyijyi

I have been flashing all thought Debian have always used the GENRIC firmware until yesterday,seeings how this is a Verizon connection i tried the Verizon firmware. Not sure if just conicendence but this is when started getting the ‘not enabled’ situation on bootup. Also worth noting just earlier today i rigged a winders machine and tried flashing the Sierra firmware to it,looked like it didnt do anything . So after this reflashed a couple times through Linux to the Generic,but looking at the results you wanted it is showing “SIERRA”,this module sure seems dogey but this is my first time messing with these. So not sure what i should be seeeing it goes without saying. Also worth noting this card shows as an EM7455B. Never have found out what the “B” designates.

Here is output of the three commands



 preferred fw version:
 preferred carrier name:  SIERRA
 preferred config name:   SIERRA_001.023_                                       
Current Time:  207              Temperature: 35                                 
Reset Counter: 3                Mode:        LOW POWER MODE                     

Thank You

seems the response of AT!IMPREF is not complete.
Here I have just tried:

Current Time:  840              Temperature: 30                                      
Reset Counter: 1                Mode:        ONLINE                                  
System mode:   LTE              PS state:    Attached                                
LTE band:      B3               LTE bw:      20 MHz                                  
LTE Rx chan:   1385             LTE Tx chan: 21150                                   
LTE CA state:  NOT ASSIGNED                                                          
EMM state:     Registered       Normal Service                                       
RRC state:     RRC Idle                                                              
IMS reg state: No Srv                                                                
PCC RxM RSSI:  -56              RSRP (dBm):  -82                                     
PCC RxD RSSI:  -94              RSRP (dBm):  -131                                    
Tx Power:      --               TAC:         0462 (1122)                             
RSRQ (dB):     -6.4             Cell ID:     04A54116 (77938966)                     
SINR (dB):     28.8                                                                  

Manufacturer: Sierra Wireless, Incorporated
Model: MC7430                           
Revision: SWI9X30C_02.36.00.00 r8395 CARMD-EV-FRMWR2 2020/10/28 06:33:51
MEID: 35907406009754                    
IMEI: 359074060097542                   
IMEI SV: 22                             
FSN: LU626300170410                     
+GCAP: +CGSM                            

 preferred fw version:                                                
 preferred carrier name:  GENERIC                                                    
 preferred config name:   GENERIC_002.077_000                                        
 preferred subpri index:  000                                                        
 current fw version:                                                
 current carrier name:    GENERIC                                                    
 current config name:     GENERIC_002.077_000                                        
 current subpri index:    000                                                        


Thank you for getting back. This is what puzzles me,All of the AT commands i see in posts,this never echos about half,of what others are showing should be a an echo. I am using minicom as the connection. I did try putty and never see any returned characters. Not sure what this is. What little i used in the past for serial I have always used picocom. Never can get it to show anything either.
Kind of wondering if this module may be half toast. This was a new sealed unit,straight from China !
I will try and use putty with the same commands you wanted.


These are the three commands. This time I used picocom. With Putty i am getting no echoe? I am connecting to /dev/ttyUSB2 just to verify.

Type [C-a] [C-h] to see available commands
Terminal ready


preferred fw version:
preferred carrier name: SIERRA
preferred config name: SIERRA_001.023_0
Current Time: 2431 Temperature: 35
Reset Counter: 3 Mode: LOW POWER MODE


I did try resizing terminal window,yada,yada,didnt make any difference.
Thanks again

you need to enable echo by “ATE1”

Screenshot from 2021-09-27 20-35-33

For right now,I have justa new blank sim in,Does this effect the output of the At!gstatus? output.

the root cause is on the at!impref where carrier name and config name are mismatched.
Did you try the latest FW by EXE file on release 27?


Yes,i did the EXE at work today on windows box… it appeared nothing ever actually wrote toe card,but a you can see in the mismatch,this is the SIERRA. yes #27 is what i chose. I only have Linux at the house,other than Windows VM’s…
Thanks for helping on this,

how about EXE? e.g. AT&T, will it change the AT!IMPREF to be matched?


I did rig up a Windows machine and actually flashed with Generic.exe # 27 firmware. As soon as modem rebooted after flash completed, the pci-e adapter now has the led blinky light showing again. Was wondering if maybe the module had partially died.
Put it back in the host Debian Bullseye machine and the led is showing again& it is enabled. !
Not sure why have so much trouble flashing through Linux utilities. I have tried about all possibilities this way.

Thanks for helping.