SMTP Internet Protocol Feature not activated


#1

Hello everyone,

Currently I develop an application to send an email based on DOTA example, it works well when I tested it .
But when my customer try it with different SMTP server, they got this error:

I use SMTP authentication type WIP_SMTP_AUTH_NONE, does this makes the problem?
I have no idea with this error, does anybody know what’s the problem or maybe a/some documentation about it?

Thanks in advance,

Regards, mus_wiguna


#2

It means that you need to contact your Distributor, and pay to have the Internet Protocol Feature activated in your device.


#3

Thanks Awneil,

So, contact the Distributor to have Internet Protocol Feature activated is the only way?
Is there any other solution? update the firmware maybe?

I bought one Fastrack Supreme, but I could use it to send an email without this error.
I didn’t update or change anything. Mine and my client’s fastrack are the same: Fastrack version, firmware version,etc.
I have checked it with AT+CGMR and ATI3.
The different only that We got the modem from different Distributor.

Thanks in advance,
Mus_wiguna


#4

Hiya,

Check out the result from AT+WCFM=5 between the two modems (and chech the AT commands guide on how to decode the result).

Yes.

No.

Get onto your distributor - they’ll know what to do.

ciao, Dave


#5

Thanks Davidc,

I will go to Distributor to ask them.

Regards,
mus_wiguna


#6

So the difference is that one distributor sullpied a Fastrack with the feature enabled, and the other distributor supplied a Fastrack with the Feature disabled.

Again, this is why you need to discuss your requirements fully with your distributor to ensire that you get all the required features enabled!


#7

Well, you could implement the SMTP protocol yourself - from scratch…


#8

:stuck_out_tongue: you could even use an external tcp-ip-stack :wink:


#9

Indeed!

One more time:

See: viewtopic.php?f=7&t=3766&p=15530&hilit=wiki#p14703

And: viewtopic.php?f=23&t=3922