SL9090: move to an active state


SL9090 module is used by me for HW design.
I have faced such trouble: regardless of W_DISABLE pin state, the module starts in LPM mode and doesn’t accept command AT+CFUN=1 (+CME ERROR:). Command AT+CFUN works only with 0,4 and 7 parameters.
May be exist another way to move module to active state?

I will be grateful for the help.

Hi Serge,

Maybe the firmware/image was lost or an invalid firmware/image was loaded…
Can you check with your distributor or FAE to get the right FW?



Thanks for answer.
I’m afraid I won’t get from my dealer a clear answer :frowning:
I watch a response to the command AT+GMR:
SWI6600X_02.00.00.04AP R2484 CNSZXD00000132 2013/01/15 20:26:19
Can I check the correctness of firmware?
Perhaps, I’m able to load correct firmware independently?
Moreover, modem is responsible ERROR for most commands from datasheets “Extended AT Command Reference” 2130616 Rev. 8


Hi Sergey,

SWI6600X is not a carrier image, thus it doesn’t register nor response to AT command normally.

Again, please check with your distributor for tool for firmware upgrade and recovery.


Hi Louis,

I’ve received a last image. Modem is showing signs of life. Thanks you.
Pls give a hint, SL9090 works with simple GSM SIM card or USIM is suitable?


Hi Serge,

Sorry for come back lately.

According to PTS:

Section 1.1, interfaces supported include:

  • 3V / 1.8V SIM interface
  • USIM

Kindly refer to PTS doc for more info.

Thanks a lot!

I’ll be attentive next time in time reading datasheets. :blush:

I watch such answer on command AT!BAND?:
“Unknown band mask. Use AT!BAND to set band.”

Should I set appropriate band?
When I apply my band, AT!BAND? shows all the same answer.
“Unknown band mask. Use AT!BAND to set band.”

May be changes will apply after reset?


Sorry to come back late… I guess you have the answer already?

For !BAND, maybe the band mask configured is not the suggested one.
Still, you can check the currently configured band mask bit.

!BAND setting is effective and save automatically.

Sometimes the AT+CFUN=1 is a locked command. Then it requires the

For most devices there is a STARTLPM configuration that you can access with the AT!CUSTOM command. I suggest that you check it.