MC8705 Boots with +CFUN=0


#1

Hi,

I have a substantial quantity of MC8705 modules (about 300) that have been sitting in stock for what I assume may be years (Firmware Revision: T1_0_3_2AP R361 CNSZXD00000061 2011/04/15 17:40:48). These get installed into a carrier board running embedded Linux.

Of the 10 modules I have checked so far, all of them seem to start up disabled (i.e. AT+CFUN? returns +CFUN: 0) before a manual disable/re-enable of the modem’s power supply rail or by manually setting +CFUN to “1”.

I have tried upgrading to a newer version firmware using the T3.5-Release11-T3_5_6_7bt-T3_5_6_7ap.exe one-click tool but to no avail.

I am comparing these modules to some test cards that I have been using for years without any problems. These test cards have firmware T3_5_6_7AP R813 CNSHZ-ED-XP0031 2014/11/10 18:11:43.

I need these modules to boot enabled and do not want to have to send a command in order to do this.

Has anyone else observed an issue like this? Or is it likely there is some hardware updates between then (back in 2011) and now that would result in behaviour like this?

Thanks.


#2

Some additional info of one of these disabled modems:

Manufacturer: Sierra Wireless, Incorporated

Model: MC8705

Revision: T1_0_3_2AP R361 CNSZXD00000061 2011/04/15 17:40:48

IMEI: 353567043449967

IMEI SV: 2

FSN: CC31585396310

3GPP Release 7

+GCAP: +CGSM,+DS,+ES

AT!GSTATUS?

!GSTATUS:

Current Time: 29 Temperature: 30

Bootup Time: 1 Mode: LOW POWER MODE

System mode: WCDMA PS state: Not attached

WCDMA band: IMT2000 GSM band: Unknown

WCDMA channel: 10700 GSM channel: 65535

GMM (PS) state:NULL —

MM (CS) state: NULL —

WCDMA L1 State:L1M_STOPPED RRC State: DISCONNECTED

RX level (dBm):-55 (Not updated)

AT+CFUN?

+CFUN: 0

OK

AT+CSQ

+CSQ: 99,99

OK


#3

Hi,

No the age is not going to be setting them to cfun 0, this is going to bean NV setting somewhere. So just to be clear when you sent at+cfun=1 they work as expected but then when you power cycle them they run up in cfun=0 mode again?

Regards

Matt


#4

Hi Matt,

Thanks for your reply. Yes, that is correct. Setting the AT+CFUN=1, they behave as expected but yes, when we power cycle, they start up with CFUN=0 again.

One thing we did notice was the difference in customisation settings stored on both a working and non-working modem:

Working modem:

!CUSTOM:

        PUKPRMPT            0x01

        MEPCODE             0x01

        ISVOICEN            0x02

        PRLREGION           0x01

        PCSCDISABLE         0x03

        GPSENABLE           0x01

Faulty modem:

!CUSTOM:

        NOROAM              0x01

        PUKPRMPT            0x01

        MEPCODE             0x01

        ISVOICEN            0x02

        PRLREGION           0x02

        PCSCDISABLE         0x03

        DISFDNPDPCHK        0x03

        GPSENABLE           0x01

        STARTLPM            0x01

        GPSLPM              0x011

Is it possible the “STARTLPM” value could be the cause of this? And do we need a password to set these values?

Thanks,

Richard.


#5

Can you try below?

AT!ENTERCND=“A710”
AT!CUSTOM=“STARTLPM”,0
AT!RESET


#6

Hi,

Yes that fixes it!

Thank you very much!

Richard.


#7

Richard,

Yes this is the problem, it is defined as follows.

“STARTLPM”—Enable/disable LPM (Low Power Mode) as the startup mode for
the user equipment.
:
• 0 = Disabled
• 1 = Enabled (start UE in LPM)

To turn it off send the following

at!entercnd="A710"
at!custom=0,"STARTLPM"
at!reset

Regards

Matt