SL8082 QSC6270 CREG=0,2 error


#1

Hi all,
I am using SL8082 GSM modem with micro-controller.
I am having problem with GSM registration, If i poll the status of registartion with CREG CMD i get response as (0,2) saying trying to connect, I polled for 5min but status is same.
If I issue the command CSQ for signal strength, response is : error: operation not allowed.

I tried with COPS = 1,2, 23415 // manual operator selection for Vodafone UK but this also does not works,

can anyone help me more on this.

Thanks in advance


#2

It’s not a modem - it’s just a bare module

sierrawireless.com/en/produc … L808x.aspx

With a modem, all the hardware design is done for you; but you have to do all your own hardware design for a module like this.

So, the question is: is your hardware design correct?

In particular, is your power supply design correct :question:

See: https://forum.sierrawireless.com/t/faq-forum-wiki/3491/1

And: https://forum.sierrawireless.com/t/problems-running-tlemetry-samle-creg-0-2/3636/6

and many more…

Do you have good UK-Vodafone coverage where you are?

What does AT+COPS=? tell you?

Is your SIM valid?


#3

@awneil
Thanks for reply,
My hardware design & powersupply is correct,
For COPS command i get response as : (’’),0.

i tried with Different SIM, which is having well coverage & activity, but it gives same response with Modem.


#4

How has that been verified?

So the module cannot see any networks at all - clearly, it will not be able to register!

Do you have the correct frequency band(s) selected?


#5

Hi awneil,
Thanks for the reply,
Problem was with my antenna connections. solved it.

now i am trying to connect my module to the GPRS network.
What is the sequence of Configuring or setting up the module for connection.
i am referring the supported commands & 3GPP 27007-630 specifications document.
can you suggest more document for this?

thanks