HL6528RD Network Registration Fail

Hi guys, I have a critical problem that cannot register the network. I always get +CREG 0,0 and +CREG 0,2.
Sim card status is ready.
I am sure the sim card can get the network normally by testing in other bands of 2G modules.
I can search the operators’ information by +COPS=?. However, when i try to manually set the operators by AT+COPS=1,0,“FULL Name of the operator”, it returns ERROR.

I tried another HL6528RD, I got the same results. I guess it may be the firmware problem, and I upgrade it to form 2.4.3 to 2.5.1, i got the same results too. I have no idea about that. Please help.

Hi chuichunwing,

Please try to use AT+COPS=0 instead.


Yes, I tried but failed. The default is +COP=0.

Hi chuichunwing,

What is your network operator? Please show your results of the command below:



Hi Jerdung,

I get 3 operators, as it is related to the customer, I can’t show in here. The return is like that:
+COPS: (2,“xxxxxx”,“yyyyyy”,“zzzzz”,0), (3,“aaaaaaaaaaaa”,“bbbbbbbbb”,“cccccc”,0), (1,“iiiiii”,“jjjjjj”,“kkkkkk”,0),(0-4),(0-2)


The country are supported GSM 900 and 1800, so I set to 12