Sierra Wireless LX40 does not pick up incoming messages reliably

Model: LX40
ALEOS Software Version:4.15.3
Radio Firmware Version: SWI9X06Y_02.16.06.00 7605a6 jenkins 2018/06/20 17:56:12
Radio Module Type:WP7702
Carrier: Telenor Norway

I am struggling to get handling of the Incoming SMS feature running satisfactory. When sending an SMS to the router, it will usually read it (See it in the Services-SMS-“Last Incoming Message” ) the first time after a reboot of the router. Consecutive incoming messages are usually not read. On reboot the missing messages are sent from the router to the “Local Host Port” (I can see them coming in on the server in Wireshark on port 17342).

So it seems like the router is not checking for incoming messages after the first message has been recieved…

Outgoing messages runs like clockwork…

Any ideas on a setting I might have missed.

Hi @thomas2 ,
Welcome you to our community!
As far as I know, to manage incoming messages you have to select SMS mode as Outbound Only by accessing to ACEmanager → Service → SMS → select “Outbound Only” in SMS mode.
Then use SSH to remote into terminal AT command and use command AT+CMGL=“ALL” to read all incoming messages.

Thanks,