Shy Q2686RD modules


I’ve got three Q2686RD modules here that I cannot communicate with. Lights are on, but nobody is home.

I’ve put each one in the Development Board and connected to them using a hard RS232 connection from the docking station on my laptop.

None of the modules will respond to AT commands (or even just ‘AT’ - which I would expect to get even if the module is stuck in download mode).

I’ve used DWLWin (V to attempt to reflash the modules - with each module DWLWin will download the boot-loader (takes about 9 seconds), then times out at about 19 seconds with the message “Fatal timeout error: the target is no longer responding”.

It’s been a while since I used DWLWin, but have never had these issues before.

Any thoughts or pointers to get these modules going again would be appreciated.

Ciao, Dave

is it working on USB?

Are they brand new? Have they ever worked?

I gather you have others that do work?

ISTR something like that with a WMP100 board: it was the first prototype run and, IIRC, turned out to be a fault with the external memory.

Hence the question of whether these have ever worked…


No, the devices do not enumerate.

They’re not new (had them for 12 months or so), and yes I have had them working in the past (in the same dev board).

Haven’t got any more Q2686RD - but the Q2686 and Q2698 modules do work in the same dev board.


They’re dead technology here in Oz now - the Telstra 900MHz GSM system is being taken off-line in December. But … they’re still useful for testing code against when having issues with the Q2698 (of which I could write a small book about).

ciao, Dave