serial port connection for AT commands


#1

I just bought open AT SDK Development Kit Q2686.
I have set-up the H/W following the UG instructions, with all the switches as per the instructions. However, I failed to do the serial port connection to the Terminal emulator.

It seems that the AT commands are sent from the PC but no answer from the kit
Once I connect the serial cable to the com port in the PC and send AT command, both the CHARGER RED Led and the FLASH-LED start to blink.
(The same happens when trying to connect the kit via Hyper termianl from PC). I tried both UART1 and 2, both give the same result as explained above.
Note:
Without connection to the Com port, the following leds are light ON(no blinking):
Charger (Red)
Supply VBAT ( Green)
ports (UART1, 2, USB) are all Green
Ring indicator ( Yellow)

Any help is very much appreciated


#2

Hello,

As the Q2686 has no pins for GND on the connector, the only GND are the legs. It could be problematic on the starter kit, obviously you don’t want to solder the legs. I recommend you bind a little bit the legs under the panel to have better connection to the ground, it matters especially at start-up. If it doesn’t solve your problem i can only suggest trying another module.

tom