Serial port connection


#1

Hi,

I just bought open AT SDK Development Kit Q2686.
I have set-up the H/W following the UG instructions, with all the switches as per the instructions. However, I failed to do the serial port connection to the Terminal emulator.

It seems that the AT commands are sent from the PC but no answer from the kit
Once I connect the serial cable to the com port in the PC and send AT command, both the CHARGER RED Led and the FLASH-LED start to blink.
(The same happens when trying to connect the kit via Hyper termianl from PC). I tried both UART1 and 2, both give the same result as explained above.
Note:
Without connection to the Com port, the following leds are light ON(no blinking):
Charger (Red)
Supply VBAT ( Green)
ports (UART1, 2, USB) are all Green
Ring indicator ( Yellow)

Any help is very much appreciated

Medhat


#2

I had a similar problem.

Problem was that the Q2687 module wasn’t properly grounded to the Dev Kit (4 GND pins aren’t soldered onto the Dev Kit, easier to swop modules).

I just used Crocodile Clips to connect the 4 pins to any GND on the board (test point, PSU circuit or even the housing of the antenna connector).

Stef


#3

Folding the 4 ground pins beneath the board also works , but soldering them is still recommended


#4

Shouldn’t soldering just one be sufficient for grounding - while still leaving it fairly easy to usolder to remove the module… :question:


#5

Also, if you solder just one, i reccommend you solder the one closest to the antenna connector
i’ve had some problems with excessive noise comming from the module wich turned out to be a bad connection with the IMP connector.


#6

Hi.
I have the Q2687 kit and for the life of me I cant detect the target from my PC via RS232.
Im using UART1. I took the soldering advice but still nothing works.
Please help, Im fed up.
Thanks
Newbie.
Here is the error I keep on getting :frowning:
M2M screenshot.

Serial manager shot


#7

is the module turned on?
is the uart1 switch in the enabled position?
are you using a usb to serial converter?
are you sure you are connecting to the right com-port on the computer?
are you sure the connection settings are correct?
(just a few things to wonder about :wink: )


#8

Hi there. I have made sure all settings are as specified in the manuals. I am using USB to serial yes. I can choose the com port no yes? I dont think its that. Cable Im using perhaps? Thanks