Serial comms problem


#1

Hi all

Up till now we have been using the M1306B module and we are just migrating to the Fasttrack Supreme 10. I have just got the first one and I can’t talk to it over the serial connection. The power light comes on and flashes slowly so it’s obviuosly happy and connected to the network but it just won’t communicate. The data sheet says the default settings are;
Data bits = 8
Parity = none
Stop bits = 1
Baud = 115 200 bps.
Flow control = hardware

I didn’t use hardware flow control on the M1306B but have never had any problems with a 3 wire implementation. Have they changed this on the Fasttrack Supreme? I have tried tying pins 11 and 12 together on the 15 pin sub HD connector but still no go.

I still have a M1306B modem here and if I swap them around the M1306B communicates fine so I know it’s not the cable.

I have tried it at 9600, 19200, 38400 as well as 115200 but still no luck.

This should be simple but it’s got me stuck at present :frowning:
Has any body else had this problem. Thanks guy’s.

Regards
Roy


#2

I thought the M1306B did require RTS to be asserted - so you would need a a “loopback” from CTS to RTS:

viewtopic.php?f=3&t=220&p=4738&hilit=loopback#p4738

That’s the way I wire my cables for 3-wire connection to an M1306B, anyhow…


#3

Just checked in the M1306B User Manual:

This is in section 7.3 RS232 Serial Link, on page 43 of the revision 3 manual.

Exactly the same appears in section 7.4 RS232 Serial Link, on page 52 of the Fastrack Supreme User Guide, revision 1e.


#4

Hi

Thanks for the advice. It seems as though the M1306B documentation is wrong then because we have been successfully using the M1206 and M1306B modems for several years now and we only use a 3 wire implementation because we are driving these modems from a small PLC type controller which does not have any hardware control lines or handshaking. I have wired many of the cables up myself and have only needed to use RX,TX and GND for normal operation.

However with the Fasttrack Supreme the RTS line must be set high which creates a real problem for us.

Thanks for your input :slight_smile:


#5

Can you do the loopback (in the connector?) to work around this?


#6

we had the same problem.

we found that when we turned off the stack it worked

AT+WOPEN=0
AT+IFC=0,0;&W Ignore flow control

and then it worked


#7

Try dissabling serial port autoshutdown with “AT+WASR=0,1”. Without it you need to set RTS line to enable UART. This and IFC=0,0 should be enough to use just 3-wire interface.

jacfry