RV50 - Linux host - Internet connection

Hi,

I was able to connect my Linux board to RV50 via serial port, and tried to ping google and establish the internet connection, but no luck yet.

ppp0 Link encap:Point-to-Point Protocol
inet addr:192.168.15.100 P-t-P:192.168.15.31 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:5 errors:0 dropped:0 overruns:0 frame:0
TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:96 (96.0 B) TX bytes:102 (102.0 B)

On ACEManager site, I set DNSProxy to Enable, it was able to resolve the DNS address:

PING google.com (216.58.192.238) 56(84) bytes of data.

Which configurations I missed to establish the connection to internet?

Thanks in advance!

PTran

Hi PTran,
To use DNS for PPP connection, the “DNS Override” should be enable, enter DNS address -> Apply and reboot device.

Thanks,

Sorry for not being clear, it was able to resolve the address of google.com, but not able to get the response from ping command.
I don’t know why.

Did you try with “DNS Override”? Did it work?
Go to ACEManager -> LAN -> Global DNS -> DNS Override

Thanks

Hi jerdung,

Thanks so much for your reply.
I changed the DNS servers to OpenDNS’s addresses, but it still didn’t work.

I also tried to ping our own server (ourserverdomain.com, let’s say) with/without overriding the DNS. It was successfully, but google.com or any other domains.
It means the system works fine, I’ll double-check our DNS server configuration later.

Regards,
PTran

Hi,
You can try 8.8.8.8 or the DNS of network Operator (it shows on LAN->Global DNS-> Primary DNS/SecondaryDNS.
The issue does not happen at our sites.
Thanks

Thanks jerdung. I did both, but no luck yet.

Hi,

  • On ACEManager, -> Admin -> Advanced -> Ping ( Can you ping google.com?)
  • Could you help to show us the log after you send command “pppd file gsm”?
  • After dial-up, please check in /etc/resolv.conf file, is there any DNS server?

Thanks

Hi jerdung,

Thanks for your reply.

II was trying to ping google from the RV side as you suggested. But it remains the same:

PING google.com (172.217.4.78): 56 data bytes

google.com ping statistics —
5 packets transmitted, 0 packets received, 100% packet loss

The connection from our Linux board to RV50 is working fine. In the resolv.conf I saw:

nameserver 192.168.15.31
nameserver 192.168.15.31

That being said there is an issue in the configuration, maybe the our own DNS servers or something else, I don’t know.

Thanks again.

PTran.

Hi PTran,
If on RV50, you can not ping google.com, please check your cellular connection.
After device is registered to network successfully, go to LAN-> Global DNS -> check Primary and Secondary DNS ( Do these parameters show DNS server?) These DNS servers are supplied by the Operator.
If you can not use them, enable DNS Override with some public DNS at here https://public-dns.info/
-> Reboot device, and ping google.com again.

Thanks

Hi jerdung,

Thanks for your reply.
The RV50 was registered to the cellular network successfully as it’s shown the IP accquired, Cellular State Connected on Status tab of ACEManager.
It’s also possible to ping our own server from ACEManager, but google.com and other domains.
At least now we can connect to our own server for the next step.

But I still want to figure out what the root cause is?

Thanks for your time, jerdung!

Cheers,
PTran

Hi,
It could be the Operator DNS issue, could you help to share:

  • what is operator that you are using? and which DNS server IP that the RV50 is using?
  • what firmware of RV50?
  • Do you enable any VPN?

If possible, could you help to provide us the template of your device (Template -> enter file name -> Download)?
Thanks,

Hi jerdung,

We’re using Verizon, here is DNS servers are being used on the RV50 side:

Primary DNS 167.132.254.229
Secondary DNS 167.132.254.237

Firmware Version SWI9X15C_05.05.58.05 r34350 CARMD-EV-FRMWR3 2017/09/25 01:53:06

All VPNs on VPN tab are disabled.

For some reasons related to the policy, we can’t send you the template for now, so sorry about that.

Thanks,
PTran

Is it successful when you ping 8.8.8.8 or 167.132.254.229 from ACEManger?
And could you please try using nslookup to query the DNS server from your Linux host?
Thanks,

Hi,

This is what I got from ACEManager:

— 8.8.8.8 ping statistics —
5 packets transmitted, 0 packets received, 100% packet loss

PING 167.132.254.229 (167.132.254.229): 56 data bytes
64 bytes from 167.132.254.229: seq=0 ttl=55 time=342.431 ms
64 bytes from 167.132.254.229: seq=1 ttl=55 time=127.996 ms
64 bytes from 167.132.254.229: seq=2 ttl=55 time=127.577 ms
64 bytes from 167.132.254.229: seq=3 ttl=55 time=187.020 ms
64 bytes from 167.132.254.229: seq=4 ttl=55 time=175.821 ms

— 167.132.254.229 ping statistics —
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 127.577/192.169/342.431 ms

Thanks

Hi Ptran,
This issue does not relate to RV50 or DNS issue. The device can reach DNS server and it can resolve google.com to 172.217.4.78. It seems that Verizon blocks the ping packet to google.
You can try some connections from linux host to see that it can go to internet or not ( not ping)
If it can not go to internet, please check your SIM card and contact Verizon.

Thanks,

1 Like