RV50 has finicky COM connection after updating to 4.8.1

Hi Experts,
We have updated around 30 of our RV50 wireless modems firmware to version 4.8.1 (from 4.5.x) following the security bulletin. The modems have some issues with the COM port connection now after the update. The modems were working fine with a sensor feeding each of them some data through the COM port before the update.
Now, many of our modems just stopped forwarding data from the COM ports. Some of them still forward data, but in an intermittent fashion. One out of our 30 updated modems seems to work normally.
It’s not a COM port configuration issue. We haven’t changed the settings after the firmware update, and we found out that by toggling the hardware flow control a few times, the problem improves. We started from a “disabled” HW flow control state to a “disabled” HW flow control state for the COM port, but somehow toggling a few times that option helps the situation. So it looks like there are some bugs in the COM port part for the 4.8.1 firmware for the RV50.
These wireless modems are feeding us critical data, so before Sierra Wireless has a fix, does anyone has 4.5.x firmware for RV50 for us to flash back to? We tried looking online ourselves, and only the 4.8.1 version is available.

Thank you very much!


Not sure if you’ve found a solution. I have the same issue. Modem is online and accessible however it wont pass data through the comm port. A reboot usually brings it back, however it’s not set in stone how long it will stay up. Sometimes a few hours or up to 24 hours. I do have the modem set under advanced to reboot every 2 hours on it’s own but only a manual reboot will make it come back.

We haven’t found a solution yet. For our case, restarting the modem doesn’t even help. I contacted Sierra Wireless support as well, they suggested us to try flashing the firmware to an older 4.7 version(available here: source.sierrawireless.com/resou … -packages/). We tried that, but it’s still the same for us. They claimed that we can’t revert back to 4.5 after we have flashed to 4.8.1.
We have a Altus K2 data logger connected to the wireless modem through the COM port. Out of curiosity, do you have same thing?
I guess if we both try to bug support, maybe they will prioritize this higher too.

Thank you, and good luck!