Reset Loop


#1

I’m caught in a reset loop and can’t get out of it in the way I have before. What I normally do is send an “at+wopen=0” from hyperterminal. Because I usually can’t type it fast enough, I’ve written it into a file and then do a “send file” from hyperterminal. But the thing causing the reset loop is right at the beginning of the code and there is no response at all from the keyboard.

Dan


#2

You’ll have to use DWLWin to reload the firmware.

This requires access to the BOOT pin - if you don’t have access, you’ll have to get your distributor to do this for you.

NB: the ‘BOOT’ pin on the Fastrack Supreme’s 15-Way connector does not work (it is not connected internally).

My Distributor recommends the following:
To prevent this happening again, have your adl_main() function just start a short timer (a couple of seconds) and do nothing else;
Then make your “real” application start in the timer handler.
This will guatrantee you a short period in which to send the AT+WOPEN=0 before your application can do anything “naughty” to crash the unit…

I recommend that you follow his advice! 8)


#3

BOOT pin on the Supreme is well connected. Apply 1V8 to activate the boot feature.

And, sometimes there is a small time window after reset, when you can enter disable command. Put AT+WOPEN=0 in your paste buffer and use ctrl/v (right click context menu / paste to host in Hyperterminal). Don’t forget trailing . This can be much faster then manual typing.


#4

Are you sure?

I was advised that it isn’t connected in the 15-way D-type - only in the 50-way connector for the IESM (where the 1.8V output is also available)

Have you actually tried this?

What would you recommend as the 1.8V source?


#5

A couple of other people have tried - without success:
viewtopic.php?f=53&t=1872&p=6911&hilit=boot#p6911
viewtopic.php?t=1789&highlight=fastrack+supreme+boot


#6

I can confirm, that boot pin on FS in the 15-way D-type is working all right. The only difference I’ve noticed is that the modem doesn’t stay in a boot mode as M1306B and other modems did. To use DwlWin you have to initiate the download/ereasure process by pressing the START button and THEN reset/power cycle FS with the BOOT pin connected to ground - i.e metal plate on chasis (I do it with throu 1k2 resistor - just in case). After that DWLWIN starts to do it’s job.


#7

Now that’s really confusing! :open_mouth: :confused:

Do you apply 1.8V to the BOOT pin to put a Fastrack Supreme into BOOT mode, or do you gound it?! :confused: :confused:

I tried grounding it (as for the M1306B) and it didn’t work - which is when I received the advice that the BOOT pin is not connected in the 15-pin connector.


#8

I ground it. It seems that FS is in a boot mode for a very short time. If DWLWIN is not started you won’t notice anything, but if it is already waiting for modem then the transfer should start. I got this by trial and error and it has been used on over 30 FS’s with no problem.

Step by step:

  1. Start DWLWIN
  2. Press START on DWLWIN
  3. Unplug power cable from modem if it is plugged in
  4. Conneecto BOOT pin to ground.
  5. Plug in the power cable while BOOT pin is grounded
  6. Downloading starts…