Registering to BTS


#1

Hello friends,

I’m very new with wavecom.There is q26 development KIT on my hand now,with q 2686 wireless CPU on it.

When you give energy to the module,How do you understand it is connected to BTS and registered.I placed SIM card and connect antenna but it is not registered when I gave energy.Is there any LED that indicates it is seraching or it is registered to the network.

This question is very easy to answer for a person who used wavecom product.I have just started today and I want to see it registered to the network and then to send at commands using HyperTerminal of windows xp.

Note:I haven’t installed Open AT software to my machine yet and also I’m thinking it is not necessary to make what I said now.(Only to see it is registered and to see takes at commands and responses them)


#2

Hi,

there is a Flash-Led on the kit which is blinking when the module is connected to network. Otherwise the led stays on. Please be sure that your sim card has no pin when you expect plug an play. You can also monitor the registration status with the at+creg command using Hyper Terminal.

Best regards, Marcus.


#3

Thanks ,Marcus

at+creg? response is 0,2

so it is not registered and ME currently researching for a new operator to register.

I think it is because of SIM card but I didn’t understand what you meaned with :“Please be sure that your sim card has no pin when you expect plug an play.”

If you make it more clear I will be happy.

Thanks again,

Ergün…


#4

Hi Ergün,

what I tried to say was when the SIM CARD has a pin then you must first enter that pin (at+cpin=xxxx). After that the modem starts searching for an operator.

Best regards,

Marcus.


#5

Ok I understood Marcus.But It doesn’t need pin code because I disabled pin asking.Problem is not that.

On some KITs there is a “power on button” except power supply switch on/off.I could not see a button like this on q 26 development KIT.Isn’t it necessary to control the energy on the module with a simple button as on keypad.

Or what can be the problem.

Thanks…


#6

Hi Ergün,

when the module response at-commands it’s switched on. Is the connection to the antenna correct? On my kit this “small piece of copper” (the contact to the pad on the module) broke down. And when no connection to the antenna is present you will get no net.

An other idea could be: Is automatic net search enabled (at+cops=2)?

What is the response to “at+cpin?” ? SIM PIN READY?

Good luck!


#7

If you put the SIM in a mobile phone, does the phone register OK?

What is the signal strength? - AT+CSQ

You could also try enabling the Wavecom +WIND indications - look-up “+WIND” in the AT commands manual.


#8

Thank you very much dear Marcus for your quick replies.I’m trying here your recommandations.Results:

1)at+cpin? command turns like…
at+cpin?
+CPIN: READY

2)at+cops?
+COPS: 0,2,28603

it means automatic net search enabled.

How can I test the antenna?It looks undamaged?

Is there any possibility comes to your mind related to solution of the problem?


#9

Hi Ergün,

You get in the answer to the “cops”-command an operator (28603). It seems to me that you are connected to the network! Try to call the module. (The answer to creg should also be X,1)

Best regards, Marcus


#10

As suggested earlier, use AT+CSQ to read the signal strength!

Have you tried the SIM in a phone?

Or the +WIND indications?

What happens if you try to dial a call?


#11

Thanks awneil for your advice,

Yes I’m using SIM card in a mobile phohe with no matter.It registers to the network.So from this result we can say There is no matter with SIM card I think.(I applied also wind indication for testing SIM card is inserted or removed.It works)

I’m giving the result related with the at+csq command:
at+csq
+CSQ: 19,0

From here, received signal strength is normal.

What do you think?


#12

Thanks Marcus,

if I connected to the network must the flash LED start blinking?It is on constantly.Not blinking?

And also at+creg result is same:

at+creg?
+CREG: 0,2

Best Regards,

Ergün


#13

Hi Ergün,

your modem behaves strange. Normaly when you get an operator on at+cops you should be connected to network (creg=0,1). The flash led should then start blinking. What version of firmware you have? I think 660_full is the latest version (you can get the version with “ati3”). Sometimes it is the easiest way to flash the firmware to get definit states.

Good luck, Marcus.


#14

Thanks Marcus,

I think, I saw the problem.It is related with IMEI number registration.

I don’t know whether it is applied in all countries but in our country,it is a mandatory to register the IMEI number of your machine to the related association(Telecommunications Association).If you don’t , you cannot use the GSM system.

I controlled if the IMEI number registered using the web site of this related association ,it seems not registered.

Consequently,the reason to tis problem is IMEI number registeration with a high probability.

Thanks for your helpful effort.

Best Regards…


#15

Hi Ergün,

yes, that was tricky! In my country all registration is related to the IMSI (written in SIM CARD). The IMEI is related to the hardware (phone or mobile). The IMEI inside the modem delivered by WAVECOM is just 01234… You should get your own IMEI. It is free of charge under babt.com (we got our own IMEI within 1 week).

Best regards, Marcus.