Question about GCC and ARM compiler


#1

Hi,
I’m new to wavecom and OPEN AT.
I’ m very confusing.
My question is:
Can I use OPEN AT with only GCC compiler or I must work with both (GCC + ARM)?


#2

Hi gioiese,

You can use it with just the GCC compiler (it is a compiler that generates code for the ARM architecture). You don’t need the commercial ARM compiler that was required with older versions of OpenAT. For debugging you will need Visual C++.

Best Regards,
Jan


#3

Hi jan,
My previous question is relative to the debugging mode of Hello_Word.
I’m using Fastrack M1306B, OPEN AT V310, Visual C++.NET 2003 and when I press the button start of the “Remote Task Monitor” in the window of the TMT I read :

Trace HWL 1 Arm exception 1 12c0a84 900
Trace GRR 1 Unable to find the string of the remote trace in the file (ID = 4514)
Trace HWL 1 Arm exception 1 1340a90 900

and in the RTM I read :

+WIND: 3

+CGREG: 0

+CREG: 0

+CGREG: 0

+WIND: 1

+CREG: 2

+WIND: 3

+CGREG: 0

and after null .

Can You Help me?
Thanks
Hi


#4

Hi Gioiese

Are you useing the 655 firmware supplied with openat 3.10?
You normally get the arm exception error if you use the wrong Firmware
You can check using ATI3 command
or you might already have an application running on the modem
You can stop it with:
AT+WOPEN=0
AT+WOPEN=3
AT+WOPEN=4

Best regards
Walter


#5

Hi Walter
Yes, I’m using the 655 firmware supplied with openat 3.10.

But for Fastrack M1306B wich firmware or open at version can I use?

Thanks
Hi


#6

Hi Gioiese
You can use the following OpenAT versions
V3.03 OS 6.51a or 6.52
V3.04 OS 6.52
V3.10 OS 6.55

So you app should work fine.
try to reload the “w.dwl”

Best regards
Walter


#7

Hi Walter
I’m checking ATI3 and AT+WOPEN=2 and this is the result:

641b09gg.Q2406B 1339080 041604 16:04

+WOPEN: 2,“AT v02.10”

In the file “OPEN AT READ ME” in the section “Open AT Samples”
–> “Hello World” I read :

“”"""""""""""""""""""""""""""""
Release version:
3.10
Changes
V2.00 : Initial revision
V3.00 : No changes
“”"""""""""""""""""""""""""""""

My question is:

What does not make to work the “OPEN AT SAMPLES”??? The firmware???


#8

Hi gioiese
Sorry for only replying now
Yes it is the firmware that is preventing the application from working.
You have to use X-modem to load 6.55 firmware on the modem first and then the openat 3.10 will work
6.41b is not compatable with openat 3.10 it will only work with openat2.10
you can find the firmware in the following directory
C:\OpenAT\Tools\CoreSW\655
you have to load the firmware in the following order
dwl.dwl
655__full_q2406b.dwl
655_w.dwl
but you must get another file from your distributor
“dota.dwl”
and after you have loaded these files into the modem then only will openat3.10 work on your modem
Best regards
Walter


#9

Hi Walter,

I am also new to OPEN-AT development. I have the same problem as gioiese. I got those ‘HWL 1 Arm exception’ and ‘Unable to find the string’ error messages.

I am using a Q2400A module. The module is running “AT v02.11”

In my C:\OpenAT\V303\Wavecore Core Software\ directory, I found these files:
dwl.dwl
351a_full_q2400a.dwl
351a_w.dwl

Should I download the above files to the module? Will it compatable will OpenAT3.03?

Thank Millions!
Andrew


#10

Hi Andrew
Yes you have to load the files first
Here is a compatibility Table for OpenAT thanks to Wavecom
If you follow this table it will always work :wink:
Best regards
Walter


#11

Hi Walter,

Thank you so much indeed. It works now.

However, occassionally TMS will show these messages:

  • Trace L3RR 1 Unable to find the string of the remote trace in the file (ID = 4102)
  • Trace L3RR 1 Unable to find the string of the remote trace in the file (ID = 4795)

Is it normal and should I do something to handle it?

Also, some programming questions:

  1. I want to write an application which will start automatically when the module is powered on. Is there any sample code or setup procedure?

  2. There are very limited information on OPEN-AT programming on the SDK CD. Is there any useful references on the Internet?

Many thanks!
Andrew


#12

Hi Andrew
Any other trace except CUS4 you can ignore
L3RR = radio resource on layer 3
The data received is encypted and you need a propper work space to decrypt it.
And you do not have this kind of file.
So don’t worry about those kind of strings.
You only need to worry about
“HWL 1 Arm exception”
and “CUS4 traces”
If you load any application on the modem and you activate with AT+WOPEN=1,then it will start everytime you start the modem.
For documentation you have to read the ADL user guide
it is the best resource that you can use.
Best rgards
Walter


#13

hello,

I tried to download the following files in sequence and i dowload it succesully using xmodem protocol:

dwl.dwl
657__full_q2406b.dwl
w.dwl

But when i reset the modem by issuing AT+CFUN=1 it sends a message “FAULT 04 00000000”. same happen when i power it off and then power on. Please advice. I dowloaded those files to the module to upgrade the firmware of my Q2406B module for me to use OPEN AT 3.12.

Thanks in advance.

Regards,
Vonlie


#14

http://www.wavecom.com/modules/movie/scenes/forums/viewtopic.php?t=263&highlight=fault

cheers,
tom