Q24 on it's own PCB


#1

Hello,

I’ve placed the Q24+ with SD on it’s own PCB which consists of only the 60 pin header and the two capacitors on the 3mm power line. Each of the 60 pins goes out to headers so that they can be accessed when necessary. I’ve connected the module as per the documentation dictates (Q24 Series Customer Design Guidelines) and measuring the VCC which is pin 40, I do not get the 2.8V. What I am trying to do is connect one controller directly to the wireless module without the use of a MAX chip or signal converter. I’m only using the UART to communicate to it so I only have RX, TX, and Ground. I’'m powering the Q24 with 3.8V and these are the values that I am getting:

pin 6: ON/OFF switch = 3.8V
pin 50: SIM_PRES = 0V
pin 40: VCC = 50mV

I’m not using the battery backup so that pin (38) is set to ground. I also have CTS and RTS, each connected to a 100ohm pull-up resistor to VCC.

Can anyone please guide me as to how to properly connect the module?

Much thanks


#2

did you connect the shield of the module to the ground?
(i don’t really know the q24 module, but the q2686 has the ground only via the shield)


#3

Yeah, I sure did. Your module has the same ground shield as the Q24 it seems :slight_smile:

But, I still don’t get 2.8V out of VCC. I need help on this since I’ve tried pretty much everything that says on the documentation.


#4

Now I’ve got pin 6 which is the On/Off switch pulled up to Vbatt. I’ve got all the Vbatt pins connected to 3.8V, I got TX from microcontroller to TX of Q24 and RX to RX and I still don’t get an output of 2.8V on Pin 40 (VCC).

I’ve also tied those unused pins to their respective pins.

Any suggestions?


#5

Remote hardware debugging is a nightmare at the best of times - it’s virtually pointless with no schematics and trying to dscribe the connections in a text-only form!

You need to get your Distributor in to sit down with you, with the board, test gear, and the full schematics in front of you, so that you can both see first hand and at the same time what is actually happening.


#6

vdd also to vbatt?


#7

vdd also to vbatt?


#8

Yep, that’s right. Pin 11 which is VDD is connected with the VBATT pins. So it is getting 3.8V.

Tried that and it’s a bit hard to get in touch with. However, I’ve drawn a simple picture of how I have it connected and hopefully based on that it can be determined if something is missing? I can only hope haha.


#9

You tried just connecting the module to the powerlines?
(not connecting anything else, ie disconnect the drt en rts etc.)
then try mesure the vcc. if you still get no 2v8 then there might be a problem with the module?


#10

I tried that, and I still don’t get 2V8 out of VCC. I took out the module and placed it on the development board and it works fine.


#11

something else you can try (or already have tried) is comparing your schematic to the schematic of the sdk board.
beyond that, i don’t know any more things you can try.


#12

Hi…

I am using Q2403 GSM Module and we have also developed our own Breakout board for the Module…

We faced this same problem some time back…i.e. we didnt used to get 2.8 V supply…

There is some problem with the 60 pin connector…It has got loose contacts and thus fails to stick properly with the module…

Check all your connections…from the point where you are giving upto the physical connections on the module…

There are some connections which are available on the upper side of the module…through the via’s you might be able to find them…

Check connectivity between these via’s/other connections and the connector board…

All the best…

P.S. We are now facing a problem in SIM detection… i.e. we are unable to get SIM-VCC voltage level on pin 9…
If in case, you are able to get some voltage (2.8V ideally) on this pin…then please do let me know…Thanks