project wizards and installed packages problems


#1

Is my M2M studio installed correctly?
This screen grab is after File | New | Open AT Project, expand “Open AT app” select “empty project”, [Target]ARM ELF GCC, Next, “Select all”, Next

[attachment=1]proj wiz1.jpg[/attachment]

I thought the SDK should be automatically installed?
But anyway go to the Package import wizard to see what there is…
[attachment=0]proj wiz2.jpg[/attachment]
What is the next step? I have followed the help processes but can’t get any further creating a project - I suspect something is wrong with the install.

As an aside why doesn’t the M2M studio show in the control panel “uninstall or change program” dialog?
(Vista Home Premium 32-bit, M2M studio Build Version 1.1.0.200908120848)


#2

“me too”

what did I do wrong?

Windows XP (although it did say it was setting it up for Vista the first time it started)


#3

See: viewtopic.php?f=78&t=3381&p=12723&hilit=uninstall#p12723


#4

well I hope in the next upgrade they at least have an uninstall entry in the start menu under “Wavecom” but why not do it the correct way and have an uninstaller in the “add remove programs”?


#5

Your M2M Studio is correctly installed, but you need to add the software packages compatible with the Wireless CPU you target for your development.
You have to grab an Open AT SDK from the website:

  • Choose your Wireless CPU on the http://www.wavecom.com/modules/movie/scenes/products/ page
  • Go to Downloads tab
  • Look for Open AT Software Suite exe file, and download it
  • Once downloaded, provide it to M2M Studio in the Packages Manager perspective by browsing for a new archive repository
  • Install packages

And it’s OK, you’ll be able to create Open AT projects from there.


#6

OK I already downloaded the Wavecom Open AT Software Suite v2.30.exe file so it’s now unzipped and I’ve browsed to the folder - what am I looking for now?
[attachment=0]folders.jpg[/attachment]


#7

Hiya,

M2M Studio is smart enough to extract what it needs from the OpenAT EXE file - without having to extract it beforehand…

To import a new archive into M2M studio:

  1. Open M2M Studio
  2. Select File->Import
  3. In the Import dialog that opens, select M2M Studio -> Open AT Software Packages
  4. The Open AT Software Packages Import Wizard starts. Follow the instructions from here. (hint, you probably want to import an archive file - so Browse to your downloaded Open AT EXE file)

Hope this helps.

ciao, Dave


#8

hmmm!
[attachment=0]import.jpg[/attachment]


#9

Arrrgh!

They’ve changed it again. My notes were from M2M Studio 1.0.2. Sorry :blush:

I do note that the first entry under General in the screenshot you posted is Archive File. Have you tried this option?

Have you looked in the help? I just searched for the word ‘Archive’ in my version and it turned up in the top couple of results.

ciao, Dave


#10

yeah!
Packages Manager tab, add new repository, select archive radio button, find zipped exe file and go…

IMO the documentation isn’t detailed enough, the help doesn’t match my version and the IDE install / flow is ambiguous for a new user what does anyone else think?

(thanks for your help Dave!)


#11

no still not working…
[attachment=1]package.jpg[/attachment]
the packages now look like they’re installed but when I go back to the project wizard I’ve still got:
[attachment=0]create.jpg[/attachment]
there’s nothing to select in any of the combo boxes.


#12

some help from the Wavecom dev. team would be appreciated.


#13

You’re close to the end of your nightmare :wink:
Actually, in Package Manager dialog (invoked from the new project wizard) or perspective, you have two views:

  • the left one lists the packages available for installation, but not installed
  • the right one lists the installed packages

Your snapshot shows that you have nothing installed.
To go further, on the left view just select the root package (Open AT Software Suite) and click the install button (or mouse right-click -> install). After confirmation the packages will be installed, and usable from the new project wizard.


#14

I did that! the snapshot is after I right clicked and installed the packages.
A dialog box popped up saying “deleting files from previous install” followed by “copy package resources to the generated plugin” but nothing appears in the tree for the installed packages.
error log - if that helps??


#15

Please give a try: invoke M2M Studio with the -clean option

m2mstudio.exe -clean

and let’s see if it fixes the issue…


#16

That worked - thanks!
[attachment=0]packages.jpg[/attachment]


#17

I was getting nowhere with this, but then found that unchecking the “filter already installed” allowed me to sort it out!