Installing M2M Studio on vista

#1

Hi

Has anyone installed M2M Studio on a Vista Business PC Service Pack 1?
I have JRE Version 1.6.0_02 (Java 6 Standard Edition Update 11 build 1.6.0_11-b03).
M2M Download process stated Java is working.
Ran M2MStudioInstaller.exe (Right click at selected ‘Run as administrator’) and installed app to default path c:\m2mstudio (No shortcuts to app created after install).
Opened c:\m2mstudio and ran m2msudio.exe as administrator. Splash screen opened then closed displaying error has occurred creating log file attached.

Any help will be appreciated

Thanks Mark

Log File

!SESSION 2009-01-20 20:53:37.742 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_11
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_GB
Command-line arguments: -os win32 -ws win32 -arch x86 -data @noDefault

!ENTRY org.eclipse.equinox.app 0 0 2009-01-20 20:53:39.489
!MESSAGE Product com.wavecom.openat.ide.product could not be found.

!ENTRY org.eclipse.osgi 4 0 2009-01-20 20:53:39.645
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:236)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:386)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)

!ENTRY org.eclipse.osgi 2 0 2009-01-20 20:53:39.770
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 20:53:39.770
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.wcc.selima_1.0.0.200901151652\ was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.selima 2 0 2009-01-20 20:53:39.770
!MESSAGE Missing host null_0.0.0.

!ENTRY org.eclipse.osgi 2 0 2009-01-20 20:53:39.786
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 20:53:39.786
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide_1.0.0.200901151652\ [5] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide 2 0 2009-01-20 20:53:39.786
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.ui_1.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 20:53:39.786
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.ebs.launch.rte_1.0.0.200901151652.jar [14] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.ebs.launch.rte 2 0 2009-01-20 20:53:39.786
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.core_1.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 20:53:39.786
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.ebs.launch.target_1.0.0.200901151652.jar [15] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.ebs.launch.target 2 0 2009-01-20 20:53:39.786
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.model_1.0.0.
!SUBENTRY 2 com.wavecom.openat.ide.ebs.launch.target 2 0 2009-01-20 20:53:39.786
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.ui_1.0.0.
!SUBENTRY 2 com.wavecom.openat.ide.ebs.launch.target 2 0 2009-01-20 20:53:39.786
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.core_1.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 20:53:39.786
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.ebs.launch.target.win32_1.0.0\ [16] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.ebs.launch.target.win32 2 0 2009-01-20 20:53:39.786
!MESSAGE Missing host com.wavecom.openat.ide.ebs.launch.target_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 20:53:39.786
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.ebs.ui_1.0.0.200901151652.jar [21] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.ebs.ui 2 0 2009-01-20 20:53:39.786
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.model_1.0.0.
!SUBENTRY 2 com.wavecom.openat.ide.ebs.ui 2 0 2009-01-20 20:53:39.786
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.ui_1.0.0.
!SUBENTRY 2 com.wavecom.openat.ide.ebs.ui 2 0 2009-01-20 20:53:39.786
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.core_1.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 20:53:39.786
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.intro_1.0.0.jar [24] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.intro 2 0 2009-01-20 20:53:39.786
!MESSAGE Missing required bundle com.wavecom.openat.ide.ebs.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 20:53:39.786
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.wcc.core_1.0.0.200901151652.jar [32] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.core 2 0 2009-01-20 20:53:39.786
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.model_1.0.0.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.core 2 0 2009-01-20 20:53:39.786
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.tcf.extensions_1.0.0.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.core 2 0 2009-01-20 20:53:39.786
!MESSAGE Missing imported package com.wavecom.openat.ide.wcc.selima_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 20:53:39.786
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.wcc.model_1.0.0.200901151652.jar [34] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.model 2 0 2009-01-20 20:53:39.786
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.tcf.extensions_1.0.0.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.model 2 0 2009-01-20 20:53:39.786
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.selima_1.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 20:53:39.786
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.wcc.selima_1.0.0.200901151652\ [35] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.selima 2 0 2009-01-20 20:53:39.786
!MESSAGE Missing host null_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 20:53:39.786
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.wcc.tcf.extensions_1.0.0.200901151652.jar [36] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.tcf.extensions 2 0 2009-01-20 20:53:39.786
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.selima_1.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 20:53:39.786
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.wcc.ui_1.0.0.200901151652.jar [37] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.ui 2 0 2009-01-20 20:53:39.786
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.model_1.0.0.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.ui 2 0 2009-01-20 20:53:39.786
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.tcf.extensions_1.0.0.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.ui 2 0 2009-01-20 20:53:39.786
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.core_1.0.0.

0 Likes

#2

“Windows® Platform Support : Windows® XP”

Officially windows XP is supported. Why do you waste your time, instead of using Windows XP?

BR
tom

0 Likes

#3

Hi tom
Thanks for your comment.
Tried on Vista as datasheet states vista is supported and desktop pc is running vista.
XP PC has Open AT software suite installed so did not install on that in case of conflicts.
Have you tried M2MStudio on XP box with AT software suite installed?

0 Likes

#4

yes, doesn’t bite
i installed it in seperate directory.
(i must say that i only used the beta’s so far. but the last beta shoudn’t be very different from the current release version.

0 Likes

#5

Hi Tom

Thanks again. Installed OK on XP.

0 Likes

#6

I installed M2M Studio and got the same error. And Yes, the Data sheet does say that Vista is supposed to be supported. Is the datasheet wrong or is this an bug?

!SESSION 2009-01-20 21:31:09.651 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_11
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86 -data @noDefault

!ENTRY org.eclipse.equinox.app 0 0 2009-01-20 21:31:21.862
!MESSAGE Product com.wavecom.openat.ide.product could not be found.

!ENTRY org.eclipse.osgi 4 0 2009-01-20 21:31:23.083
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:236)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:386)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)

!ENTRY org.eclipse.osgi 2 0 2009-01-20 21:31:23.128
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 21:31:23.128
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.wcc.selima_1.0.0.200901151652\ was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.selima 2 0 2009-01-20 21:31:23.128
!MESSAGE Missing host Bundle-NativeCode_0.0.0.

!ENTRY org.eclipse.osgi 2 0 2009-01-20 21:31:23.137
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 21:31:23.137
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide_1.0.0.200901151652\ [5] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide 2 0 2009-01-20 21:31:23.137
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.ui_1.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 21:31:23.137
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.ebs.launch.rte_1.0.0.200901151652.jar [14] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.ebs.launch.rte 2 0 2009-01-20 21:31:23.137
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.core_1.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 21:31:23.137
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.ebs.launch.target_1.0.0.200901151652.jar [15] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.ebs.launch.target 2 0 2009-01-20 21:31:23.137
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.model_1.0.0.
!SUBENTRY 2 com.wavecom.openat.ide.ebs.launch.target 2 0 2009-01-20 21:31:23.137
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.ui_1.0.0.
!SUBENTRY 2 com.wavecom.openat.ide.ebs.launch.target 2 0 2009-01-20 21:31:23.137
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.core_1.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 21:31:23.137
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.ebs.launch.target.win32_1.0.0\ [16] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.ebs.launch.target.win32 2 0 2009-01-20 21:31:23.137
!MESSAGE Missing host com.wavecom.openat.ide.ebs.launch.target_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 21:31:23.137
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.ebs.ui_1.0.0.200901151652.jar [21] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.ebs.ui 2 0 2009-01-20 21:31:23.137
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.model_1.0.0.
!SUBENTRY 2 com.wavecom.openat.ide.ebs.ui 2 0 2009-01-20 21:31:23.137
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.ui_1.0.0.
!SUBENTRY 2 com.wavecom.openat.ide.ebs.ui 2 0 2009-01-20 21:31:23.137
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.core_1.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 21:31:23.137
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.intro_1.0.0.jar [24] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.intro 2 0 2009-01-20 21:31:23.137
!MESSAGE Missing required bundle com.wavecom.openat.ide.ebs.ui_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 21:31:23.138
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.wcc.core_1.0.0.200901151652.jar [32] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.core 2 0 2009-01-20 21:31:23.138
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.model_1.0.0.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.core 2 0 2009-01-20 21:31:23.138
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.tcf.extensions_1.0.0.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.core 2 0 2009-01-20 21:31:23.138
!MESSAGE Missing imported package com.wavecom.openat.ide.wcc.selima_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 21:31:23.138
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.wcc.model_1.0.0.200901151652.jar [34] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.model 2 0 2009-01-20 21:31:23.138
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.tcf.extensions_1.0.0.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.model 2 0 2009-01-20 21:31:23.138
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.selima_1.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 21:31:23.138
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.wcc.selima_1.0.0.200901151652\ [35] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.selima 2 0 2009-01-20 21:31:23.138
!MESSAGE Missing host Bundle-NativeCode_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 21:31:23.138
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.wcc.tcf.extensions_1.0.0.200901151652.jar [36] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.tcf.extensions 2 0 2009-01-20 21:31:23.138
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.selima_1.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-01-20 21:31:23.138
!MESSAGE Bundle reference:file:plugins\com.wavecom.openat.ide.wcc.ui_1.0.0.200901151652.jar [37] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.ui 2 0 2009-01-20 21:31:23.138
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.model_1.0.0.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.ui 2 0 2009-01-20 21:31:23.138
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.tcf.extensions_1.0.0.
!SUBENTRY 2 com.wavecom.openat.ide.wcc.ui 2 0 2009-01-20 21:31:23.138
!MESSAGE Missing required bundle com.wavecom.openat.ide.wcc.core_1.0.0.

0 Likes

#7

After initial investigation, it looks like a technical issue on the Wavecom side. We’re going to remove Vista from the spec sheet until we can confirm how difficult and how this is going to take to solve.

Sorry for the obvious frustration.

0 Likes

#8

I think a lot of people would have been a lot happier if Microsoft took that approach… :wink:

I think Microsoft have pretty much been forced to say the same, haven’t they…? :wink:

badxp.com/114/microsoft-admi … a-mistake/

0 Likes

#9

Hi ,
I have the same probleme , the solution is to modify the compatiblity setting , you must do win xp pack 2 compatibility system

0 Likes

#10

I’m using Vista Business for M2M Studio. As stated, setting the compatibility mode of the install and the final exe to XP SP2 worked for me.
I have run into another problem. I don’t know if it is related to M2M Studio, TMT, or just the way things are.
I recently installed the periodic updates from MS – and coincidently – installed M2M Studio – and coincidently – started using TMT for some debugging.
Now, from time to time, Vista crashes and does the equivalent to a blue screen. When I restart things, the Vista “Oops!” dialog actually uses the phrase “Blue Screen”.
So, is it the last update of Vista or one of the Java apps that is taking down the OS?
It does not happen when in a Java app, necessarily, but I think that either one is running or has run since the last boot.
Anyone seen such a thing?
D

0 Likes

#11

It seems that using M2M Studio & TMT at the same time is quite not stable…
I have issues if I try to do so; but by switching from the one to the other with closing the programs each time, it’s working correctly.

0 Likes

#12

Note that the first maintenance release has been uploaded to the Wavecom site in the form of V1.01. Included is C++ support, Vista support and a whole bunch of other improvements and fixes.

The full release note is here http://www.wavecom.com/modules/movie/scenes/developers/index.php?fuseAction=article&rubric=developers_RN_M2M_Studio&article=developers_RN_M2MStudio_101&rubricLinks=developers.

Get the new version here: http://www.wavecom.com/m2mstudio

Keep posting your feedback in the forum here: http://www.wavecom.com/modules/movie/scenes/forums/viewtopic.php?f=78&t=3118 :smiley:

0 Likes