1.1.1 Updates not working [SOLVED]


#1

Hi,

Has anyone got the update or install features to work yet. I get “cannot complete the request”, “this installation has not been configured properly for software updates” with selecting either Help->Check for Updates or Help->Install New Software. It seems this might, or might not, be an Eclipse problem – searching for those exact strings on google gets a number of replies that are sort of the same problem. The suggested fix – a line inserted in config.ini doesn’t work here – that file isn’t present. It does seem the problem is fixed however – if I could get the update… No – the autoupdates don’t work for other than Wavecom supplied code.

Regards,
Gavin.


#2

M2M Studio configuration file is m2mstudio.ini (rather than config.ini)
What is the ini file fix you are suggesting?
Can you try and keep us informed?
Thanks


#3

Found this after a google search – others have the same problem.

All of you experiencing this, try running the following in a terminal:
sudo sed -i ‘s/SDKProfile/PlatformProfile/’ /usr/lib/eclipse/configuration/config.ini
You may have to have to delete your ~/.eclipse and possible also create a clean workspace for this to work.

From memory that line for sed searches for SDK… and replaces it with Plat… I’ll give it a try.


#4

I think it is actually config.ini in the \configuration directory, but it doesn’t have a line in it like that.

Nearest is ‘eclipse.p2.profile=M2StudioProfile’ and that file exists.

Hmm – not sure where to take this – can anyone who has 1.1.1 installed get updates ?


#5

Are you running M2M Studio under Linux :question: :question:
How did you install it? You should have installed it over an existing Eclipse platform using software updates… Is it the case? And if so, does it mean that software updates are getting not functionnal after the M2M Studio plugins install?

Sounds correct… Can you check the p2\org.eclipse.equinox.p2.engine\profileRegistry\M2StudioProfile.profile directory exists in your M2M Studio install?

Sorry but you’re the first one experiencing such issues…
Can you try to perform another install to another location, to check if it’s a reproducible behaviour?
Please can you give details on your system configuration?

Thanks.


#6

As it’s not now clear, and 2.31 can’t be updated, how should I be updating to 1.1.1 ?


#7

If I understand well, your target is to have a running M2M Studio 1.1.1 install with Open AT Software Suite 2.31
First of all, don’t use the Open AT Software Suite installer. You have to install first M2M Studio 1.1.1, then install the 2.31 packages inside it just by adding the Software Suite .exe file as a new package repository.

To be clear: it’s definitely not possible to upgrade a former M2M Studio (I mean 1.1.0 or older) to 1.1.1: you have to make a clean new install in a new directory, using the provided software installer.
Then from 1.1.1 you should be able to install other Eclipse plug-ins.


#8

That’s exactly what I have done, except 1.1.1 doesn’t allow updates OR anything to be installed via either of the choices on the Help menu. Java incidently is fully up to date.

I didn’t use the .exe as a repositry – I used the RarSfx subdirectory that the 2.31 loader creates to install the packages – which works. I’ll try the .exe, but this isn’t about the packages – it’s about any Eclipse updates.

Are you saying that updates from inside 1.1.1 (Help Menu -> Install or Help Menu -> Updates) should work, or works for you ?. Can anyone else report on updates off the help menu working on a virgin machine 1.1.1 install ?

Regards,
Gavin.


#9

Well, i can report them as not working.


#10

This problem popped up while trying to access
help-> about-> installation details

eclipse.buildId=unknown
java.version=1.6.0_14
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=nl_NL
Command-line arguments:  -os win32 -ws win32 -arch x86 -data @noDefault


Error
Sun Nov 29 10:35:00 CET 2009
Could not locate the running profile instance. The eclipse.p2.data.area and eclipse.p2.profile properties may not be set correctly in this application's config.ini file.

org.eclipse.equinox.internal.provisional.p2.core.ProvisionException: Could not locate the running profile instance. The eclipse.p2.data.area and eclipse.p2.profile properties may not be set correctly in this application's config.ini file.
	at org.eclipse.equinox.internal.p2.ui.sdk.ProvSDKUIActivator.getSelfProfileId(ProvSDKUIActivator.java:170)
	at org.eclipse.equinox.internal.p2.ui.sdk.PreloadingRepositoryHandler.execute(PreloadingRepositoryHandler.java:49)
	at org.eclipse.ui.internal.handlers.HandlerProxy.execute(HandlerProxy.java:294)
	at org.eclipse.core.commands.Command.executeWithChecks(Command.java:476)
	at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:508)
	at org.eclipse.ui.internal.handlers.HandlerService.executeCommand(HandlerService.java:169)
	at org.eclipse.ui.internal.handlers.SlaveHandlerService.executeCommand(SlaveHandlerService.java:241)
	at org.eclipse.ui.menus.CommandContributionItem.handleWidgetSelection(CommandContributionItem.java:770)
	at org.eclipse.ui.menus.CommandContributionItem.access$10(CommandContributionItem.java:756)
	at org.eclipse.ui.menus.CommandContributionItem$5.handleEvent(CommandContributionItem.java:746)
	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1003)
	at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3880)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3473)
	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2405)
	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2369)
	at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2221)
	at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:500)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:493)
	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
	at com.wavecom.openat.ide.Application.start(Application.java:202)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:194)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1311)

#11

I had got to roughly that place – other users of Eclipse P2 have the same issue for the same reason. It’s fixed now, but only if updates worked. Sigh.

For those trying to fix this;

Installing the Current Eclipse 3.5 Galileo (it’s actually 3.51) doesn’t work with M2M Studio – too many resource “matching issues”
Installing an older 3.50 doesn’t work – it updates itself before the M2M Studio plugins install and then the line above applies.

I really, really wish Wavecom would give us a clear, clean working version that supports both Q2686 and Q26 Extreme. (Preferably one that a usable editor can be plugged into :slight_smile: )


#12

OK, seems to have an issue with the software installer. We’re looking forward to fix it ASAP.
Please note it seems to depend on the user’s system, since we have several test configurations here without any software update issues.

As a workaround, the installation procedure described in the release note (at http://www.wavecom.com/releasenotes/m2mstudio/1.1.1) for installing M2M Studio plug-ins over an Eclipse platform is OK (just tested again 2 minutes ago), and then you get software updates fully functionnal.


#13

I’ve tested a number of machines, all Win XP, all up to date, all don’t update. Just noticed one thing new – the install seems to give issues if IE8 is running while installed.

I’ve just installed Eclipse 3.5.0 C++ Edition again. This time it has run, and Updates/New Install worked until M2MStudio was installed, and now doesn’t, same error as I posted in the other thread.


#14

same experience here

let me elaborate a little:
it seems to occur after i installed the software packages from the OpenATSoftwareSuitev2.31


#15

Just confirmed this.
Updates stop working after importing the packages from OpenATSoftwareSuitev2.31(.exe)


#16

I’ve come to the same conclusion, but it still seems not to be always reproducible.
I keep on investigations to provide a workaround ASAP.
Thanks for your feedback.


#17

I get a workaround:

  • In the Available Packages view, remove any repository pointing on Open AT Software Suite 2.31 package
  • Restart M2M Studio

Software updates shall be functional again after that.
Please advise if it is OK or not.
Thanks


#18

it works again.
success debugging that :slight_smile:


#19

Yep, works fine. Good skills…