Problems Getting EM9191 Working with M.2 to USB Adapters

Hello everyone,

I’ve recently acquired an EM9191 modem and am attempting to use it with an M.2 to USB adapter. However, I’m encountering some issues. Despite having Windows 10 and installing the necessary drivers from the manufacturer’s website, the modem does not seem to be recognized by my system at all. When I connect it, nothing appears, and I’m unsure of how to proceed.

Has anyone used this setup or faced similar challenges? I would greatly appreciate any advice or guidance on the steps I should take to resolve this issue.

That’s the link for adapter:

Thank you in advance for any responses!

See if this helps:

1 Like

Based on the official documentation, I have made the necessary configurations to hold the PCIE_DIS pin high to enable the USB3 interface. However, after connecting the 9190 device using a generic M.2 to USB adapter to a Windows system, nothing is detected. This behavior suggests that despite correctly setting the PCIE_DIS pin to logic level 1 to select the USB3 interface, there is an issue preventing the device from being recognized or functioning properly when connected. It’s possible that PCIe is the default interface, and further review of the hardware documentation and system settings may be required to ensure that all necessary configuration steps have been accurately executed.

did you also check pin22 for VBUS_SENSE?

1 Like

recommend your this adapter,

has switch for em919x usb mode , has good heatsink at bottom of modem.

1 Like


Thank you so much for your help! With your guidance, I’ve managed to get the device recognized by the computer, which was a major step forward. It appears that pin 22 for VBUS_SENSE was key.

Now, I am trying to get the EM9191 module to work on a Raspberry Pi Compute Module 4. When connected, it’s detected by the system and I’ve succeeded in connecting to the module’s serial interface, which is great. However, I’ve run into a challenge: although I can communicate with the module and even obtain an IP address using AT commands, this address doesn’t seem to be passed on to the Raspberry Pi’s internet interface. A wwan interface is created but it remains inactive and without an IP address.

I would greatly appreciate any suggestions you might have or guidance on what steps I should take next. What should I check or adjust to ensure that the wwan interface becomes active and correctly receives IP details via DHCP?

Thank you very much for your response and for your ongoing support.

Make sure you have enabled MBIM interface in AT!USBCOMP.
Next, you can follow the procedure below:

  1. sudo apt-get install libmbim-utils
  2. Modify /etc/mbim-network.conf to include APN/username/password of SIM card, e.g.
    owner@CNHKG-EX-001367:~$ cat /etc/mbim-network.conf
  3. sudo mbim-network /dev/cdc-wdm0 start
  4. sudo dhclient wwan0
  5. “ifconfig wwan0” should show IP address
  6. ping -I wwan0

Thank you so much for your help! Everything work like a charm!