EM9191 not found in LattePanda3Delta m.2Bkey slot

The EM9191 is not detected when installed in the m.2B slot of our LattePanda single board computer.
em9191-at-log on usb-c.txt (3.0 KB)

Please find the AT command log attached. This output was captured on the lattepanda sbc, using the Sierra dev kit with EM9191 installed, connected using USB-C cable that came with the dev kit.

the firmware in the EM9191 is AT&T SWIX55C_03.10.07.00 030.059_001

  1. Using Sierra dev board with installed EM9191 and connecting to our LattePanda SBC using USB-C cable provided with Sierra dev kit, the modem is recognized by ubuntu and works as a network adapter to go online, including to browse web sites.

  2. Using USB-C connection:

  3. “mmcli -L” successfully reports the modem information

  4. “nmcli” operations also work ok

  5. Two serial ports are seen in /dev: ttyUSB0 and ttyUSB1

  6. ttyUSB port works ok with the AT commands

  7. Have compiled and installed “Sierra Wireless USB Drivers” using “MBPL_DRIVERS_R32_ENG2-usb-src” following instructions in readme.txt. Both compile and installation seemed to work ok.

  8. Using m.2Bkey slot of LattePanda:

  9. “mmcli -L” reports “no modems were found”

Since the modem seems ok for USB-C cable use, are there any firmware settings in the EM9191 that I need to modify to enable m.2 operation?

did you check PCIE_DIS signal?

Thank you for helping!
It seems the pin 20 on lattepanda 3 delta m.2 Bkey slot is open (NC).

We made a voltage divider with
two 10k resistors between 3.3V and GND, to give us a pullup voltage of 1.65V. We wired (soldered) this pull up voltage to the pin 20.

“mmcli -L” still reports “No modems were found”
Is the Pin 20 tolerant of 3.3V? Perhaps 1.65V is not enough?

What can we try next?

Here is some information for the lattepanda 3 delta SBC m2. b slot:
From Specification - Documentation
“M.2 Key B(2242/2252/2280): SATA III, USB2.0, USB3.0, SIM”

Also, I have tried both with and without the SIM card installed in the SIM slot on the lattepanda3d.

How about pin 22?

Maybe you need to compare pin to pin voltage with the devkit

We also tried a wide variety of adapter boards with no luck. EM9191 still works great in the Sierra DevKit board. Tried adding pullup to 1.8V on the adapter boards too. I measured the various signals and have not yet found the issue. I have built a schematic using the devkit manual schematic.

Do you have any more suggestions?

Is there a reference design package to make our own PCB?

pin 20 → high (1.8V)
pin 22 → high (1.8V)

check pin 28 for power loss acknowledge
pin 24, pin 68, pin 38 → VCC (3.3V)

You might need to contact distributor for a schematic review

Btw, other user can make it work in m.2 adaptor: