EM9190 not being detected in Windows 10

My EM9190 is not being detected in my Windows 10 machine.

I have an m.2 to USB 3 adaptor for the card but it does not appear to power on. Is there a specific Sierra Wireless tool I need to install for this to be recognized?

Should I try taping specific pins?

@belusnecropolis

So it should at the very least show up in the

TBH it is unlikely to function properly with a converter off the internet as some of the pins will almost certainly be configured incorrectly which will cause the unit to not power up or not be detected correctly.

Regards

Matt

Thank you for your reply Matt. I have also tried it in the ZBT WG1608 router and a couple of EVB boards and I am still not having any fortune.

@belusnecropolis

If you have managed to get your hands on an EM91 then you must have either direct support or support from one of the distributors (as they are in high demand and not for general sale to everyone at the moment). You need to ask them for the technical documentation.

Regards

Matt

I got it off of a random listing on Chinese amazon for a bunch of money, I found the technical documents on the FCC OET website off of the public internet.

I just want to know how to turn it on, or if I need some kind of new adaptor.

@belusnecropolis

You might need one of our dev kits but if you give me the IMEI or serial number (should be written on the unit) I should be able to tell you the build standard and what I would expect it to be able to do and subsequently guide you a bit better.

Regards

Matt

Thank you Matt I sent you message with this information.

I have the exact same issue. Was it solved?

@pizzi

Yes it was an early engineering sample, you cannot use an adaptor with the unit you either need to use a specifically designed board or one of our dev kits (which is designed for it).

Regards

Matt

Hi @mlw , mine is a production run and does the same. Other modules (eg. Quectel ones) work fine with this adaptor and are correctly seen. Is there any special trick to turn the 9190 on with these adapters?
How can I send you the IMEI in a private message, so you can verify?

About the following (from the official documentation):

Updated M.2 pinout to have both USB3.1 and PCIe signals, added PCIE_DIS for interface selection

What is the default for the 9190 when plugged into a generic M2 to USB adaptor?
perhaps PCIE is default? should I tie PCIE_DIS to high to enable USB3?

@pizzi

There is no magic wand that I know of to make it work with any given adaptor board or be able to tell you why it works with the Quectel one and not the EM91, that’s just going to be luck more than anything. You need to go through the PTS, check the units requirements and then look at what the adaptor is doing.

Re the PCI vs USB question, the default state of the unit is PCI, if you pull PCI_DIS (pin 20) high for the power up sequence then it will boot into USB mode, all depends what the adaptor board is doing with this pin.

Regards

Matt

That could be the issue I’m having then. I tried the module on my ZBT router and it’s not seen there too so it’s not an adaptor only issue.

Hi Matt, can you please tell me the part # of the development board for EM91xx?

TIA
Rick

@pizzi

You are going to need to go to one of our distributors to get your hands on one (not Digikey or one of the other catalogue disti’s), I know they are in extremely short supply right now.

Regards

Matt

Understood. Can I have the part # anyway ?
Thanks
Rick

@pizzi

Pretty sure its 6001349.

Regards

Matt

thanks Matt! Appreciate it.