Problem with downloading application


#1

Hello!
When I used M2M Studio 1.0.2 this feature worked, but now with version 1.1.0 not. If I use hyperterminal Fastrack sends character $15 every second, and downloading process is regular, but if I use M2M Target Managment it sends this character once in about 8 seconds and then finishes with message “Error while performing download. Please try again.” and “*** XMODEM ERROR ***” in the remote shell field.


#2

Please can you list:

  • The Open AT OS and Firmware versions used to build your application
  • Your Wireless CPU type
  • The Firmware version that is running on your Wireless CPU

By the way, can you please make sure you were using the same Open AT OS and Firmware versions when you built your application with M2M Studio 1.0.2?

Thanks.


#3

[]Open AT OS 6.30.0.00, Firmware version 7.4.0.00[/]
[]I use Fastrack Supreme 20[/]
[]R74_00gg.FSU001 2120060 041709 19:18[/]
Open AT OS and Firmware were the same.
Baudrate 19200.


#4

And I guess your target configuration was the same (same FW version, same speed)?


#5

There was another speed - 115200…


#6

Did you make the try to download @115200 with 1.1.0, and @19200 with 1.0.2?


#7

I tried to download at 115200 with 1.1.0 and it works. At 19200 with 1.0.2 the same problem.


#8

Ok so it’s not a regression since 1.1.0; The issue is now logged for fix in a future release.
Thanks for your feedback.