Developer Studio Download App using USB


#1

I can’t seem to download my application when using the USB as the local port in M2M Studio
If i switch to Uart1 then the Application downloads without issue.

Any ideas?

Thanks


#2

You need to describe exactly what you tried, and exactly what happened - how, exactly, did it fail?

Does your target have a firmware version that supports USB firmware download?


#3

I’m using a Q2686(V7.45.0.2) connected to my Laptop(running Vista, and the latest M2M studio).

From Target Management i connect to the Serial Port(Uart1) and everything works fine, i can download my application and run it etc.

When i disconnect from Uart1 and Connect to the USB port it connects and i can send commands to the target and run my application but if i try to download a openat dwl file the window opens and i select my dwl file from the workspace and then it looks as if it is trying to download but the green progress bar never appears.

i would like to use the USB to debug and upload new code as i’m using Uart1 for my application comms.

Thanks
Mike


#4

Please can you elaborate on the Firmware and Bootloader versions displays in the Status view of DS?
Maybe you have a too old bootloader version, not supporting USB download (as awneil said).


#5

This is a perfect example of why we need more information in the ‘Download Details’ display!

See: https://forum.sierrawireless.com/t/developer-studio-1-2-0-wish-list/4928/1

At the moment, it really just tells us, “it didn’t work” - which is next to useless.

We really need to know what, exactly, went wrong - and at what point.


#6

Here are the FW Details:

“DWL”,“V08b07 “,””,“Sierra Wireless”,40272,“081408 14:10”,“61f36a52”,“00010000”
“FW”,“FW_SRC_745_17.Q2686G”,“R7.45.0.201102220653.Q2686G”,“Sierra Wireless”,2200556,“022211 06:53”,“bde44248”,“00020000”
“OAT”,“1.0.0”,“MyApplication”,“MyCompany”,73088,“062411 16:35”,“acee4562”,“00260000”
-“Developer Studio”,“2.0.0.201103101643-R6604”
-“Open AT Embedded Software Suite package”,“2.35.0.201103111042”
-“Open AT OS Package”,“6.35.0.201102280758”
-“Firmware Package”,“7.45.0.201102220653”
“ROM”,“800000”
“RAM”,“200000”
“DWLNAME”,“Q2686G”

I can’t update the Bootloader, i select the update icon in the corner of the bootloader section in the status window and select V08B11 from firmware package 7.45… then download, all appear to work but the version still remains V08b07?

Thanks
Mike


#7

Download via USB/UART2 is supported since bootloader V08b0D, so it is NOT supported on V08b07; it explains why USB download doesn’t work on your side…
Now we have to understand why you can’t upgrade your bootloader. Are you sure information is correctly refreshed after the upgrade?


#8

Yes definitely refreshed. Is there any other way of uploading the Bootloader?


#9

AT+WDWL :question:


#10

i Downloaded the Firmware package 7.45.0.2011… with DWLWIN which has fixed the problem.

+WDWL: V08b11

USB Application Download works now!

Thank you.
Mike


#11

See also: https://forum.sierrawireless.com/t/ds-1-2-download-doesnt-work-at-460800-baud/5186/1 - where, again, the lack of detail makes it impossible to diagnose the problem.