Cannot download a new firmware


#1

Hi there,

I’m working on Sierra Wireless GL6100, RS232.

I developed a custom firmware that switch the UART1 to data mode with baud rate 9600.

Throw the COM, I can switch back to AT command mode but when I try to download a new firmware I get this error from developer studio:

Error: Ati3Callback

Download file Uart_DataMode.dwl to port COM3, reload informations and check => ERROR: Timeout while handling command: class com.swi.tm.hlservices.target.internal.bundle.Ati3Callback
Download file Uart_DataMode.dwl to port COM3, reload informations and check => ERROR: Timeout while handling command: class com.swi.tm.hlservices.target.internal.bundle.Ati3Callback
Open port COM3 => DONE: Success
Open port COM3 => NO NEED TO DO IT: Success
Waiting for module detection => DONE: Target detected sn:BF2190018703300 baudrate:9600
Switch to Development mode and check => DONE: Success
Switch to Development mode and check => DONE: Success
Switch to Development mode => DONE: Success
Pause : 300 milliseconds => DONE: Success
Check dev mode unlocked => DONE: Success
Enable persistent development mode => DONE: Success
Try to unlock developement mode and check => NO NEED TO DO IT: Success
DWL File parsing => DONE: Success
Show a CONFIRM dialog with message => NO NEED TO DO IT: Success
Load model element: Target Informations => ERROR: Timeout while handling command: class com.swi.tm.hlservices.target.internal.bundle.Ati9Callback
Load model element: Target Informations => ERROR: Timeout while handling command: class com.swi.tm.hlservices.target.internal.bundle.AtWsswCallback
Load model element: Target Informations => ERROR: Timeout while handling command: class com.swi.tm.hlservices.target.internal.bundle.Ati3Callback

Is this problem related to the UART baud rete?

I try to set the baud rate (throw AT command) at 115200 but nothing has changed.

Any suggestion?

Thanks in advance!


#2

firmware or application?

normally default baud rate for sierra firmware is 115200. so in your firmware\application you have changed the baud rate to 9600? then what baud rate module was working?

Now what is the status of the modem? it’s in 9600 baud rate? are you able to communicate with the modem?

-Alex


#3

I solved the issue stopping the application at boot with the AT command, then I change the baud rate to 115200 with AT command and finally I save the this changes with AT command.

That’s works!


#4

Thank fedex, I did as your tutorial.