Downloading only worked worked once!?


#1

Hi,

Although I have quite some experience in ebedded software development, I am new to Sierra modules and its SDK. We just received 3 Fastrack extend terminals with the FXT001 modules inside (FW R74).

I installed the latest software suite from your website. In M2M Studio (1.1.1), I created a sample hello world project, compiled and started it. It worked and showed the expected debug output.

Now I modified the string a bit. I tried to run it again. It builds it and then starts downloading. A window pops up showing something like “downloading 1/51” wich immediately closes without an error message. Then it calles at+wopen=1 and the output of my previous download is shown.

Then I erased the software using Target Info, but still download (even manually) is not working. I restarted my computer, still same result.

Then I grabbed another Fastrack Terminal, and now it works. I can download different projects without a problem.

I’m not sure if this a hardware issue or did I maybe misconfigured the module somehow? Is there any way to check this in M2M Studio or do you have any suggestion what to do?

Thanks,

Jan