Problem - M1306 Showing Ascii Values - Urgent


#1

This modem M1306 what i brought recently is giving me a problem.

I’m using Hyper terminal to connect the Modem, if type any AT command it is showing ASCII/ UNICODE characters i don’t know what exactly is that.

I set the Modem at Mexico with Telcel carrier. And i set the port settings as
Bits Per Sec : 9600
Data Bits : 8
Parity: None
Stop Bits: 1
Flow Control: None

Moreover i connected the modem with a USB to my PC via a USB-Serial convertor, because i don’t have the serial port.

Please reply me asap.

Thanks


#2

That sounds like you got the wrong baudrate. Have you tried to set it to 115200?

Some USB/serial adapters are missing some control lines which might be a problem in certain cases.

Regards,

wismo_coder


#3

Please explain what you mean by that?!
The M1306 AT commands always and only ever work with ASCII-coded characters, and won’t work with Unicode.

Do you mean the modem is echoing characters as you type them?
If you don’t want that, then disable the echo with ATE0 - as for any modem.


#4

See: viewtopic.php?f=3&t=419&p=3498&hilit=rts+cts+dsr#p3498


#5

Thanks for the Reply to All.

I’m not saying that it is echoing. if i type any command in the Hyper Terminal it is showing some ASCII characters. I don’t know whether it is a ASCII/ Unicode that is what i mentioned in my Previous post.

So please give me a suggestion to make it work asap.


#6

I’m having one more problem with some other Modem.

I’m Using a WAVECOM WMOD2

I’m using Hyper terminal to connect the Modem, iI set the Modem at Mexico with Telcel carrier. And i set the port settings as
Bits Per Sec : 9600
Data Bits : 8
Parity: None
Stop Bits: 1
Flow Control: None

Moreover i connected the modem with a USB to my PC via a USB-Serial convertor, because i don’t have the serial port.

the output of the modem is shown below. [size=150]Using USB- Serial Convertor[/size]

This is the output when i connected directly to a serial port of some other system with same port settings.

[size=150]Not using Usb - serial Convertor.[/size]

If i gave any command more than once it is responding. I don’t know why.

Please reply me asap.

Thanks


#7

You mean hypoterminal is displaying junk?

This has nothing to do with ASCI!

It means that the data hypoterminal is receiving is not valid, printable ASCII codes!

Most commonly, this is because the hypoterminal settings (baud, data bits, parity, etc) do not match the modem’s settings…


#8

I have never seen this behavior. Try to find the origin of the errors by changing the cable and the computer. Hyperterminal should be fine…


#9

Thanks for your suggestions

I’m not able to find the origin of that error. If possible let me know how to find that.

Thanks


#10

What I ment is that you should exclude the cable and the computer as possibly being faulty. If the behaviour of your modem is still erratic after that you should probably contact your distributor.


#11

Let me know what is Baud Rate, whether it is based on the Carrier/ PC to Modem connectivity.

Don’t mistake me.


#12

The so-called “Baud Rate” is the speed at which a serial port works; that is, the speed at which it sends and receives data.

For two serial ports to communicate, they must both be set to the same Baud Rate - in this case, the serial ports are on the modem, and the the PC’s COM port.

You set the modem’s Baud Rate with the AT+IPR command - it is entirely independent of the GSM carrier.

Obviously, sending the AT+IPR command requires that you have the PC and Modem serial ports already set to the same Baud Rate. If you don’t know what Baud Rate the modem is set to (and it is not in “Auto-Baud” mode), you will just have to find it by trial-and-error…


#13

Thanks for your suggestion,

I’m using M1306B Modem. I just connect that with the use of Hyper Terminal & using a USB - Serial Port Converter.
If i type any thing I’m getting the junk characters in the screen. For this i Got two solutions
[b]

  1. Problem with the port settings
  2. Problem with the Cable

[/b]

Let me know these are the only problems or some other things to be consider.

Please reply me asap

Thanks


#14

Do you think you could go easy on all the colour, etc?

Port settings are by far the most likely cause of this; until you can state with 101% certainty that you have the port settings correct - on both the modem and the PC - there is little point worrying about anything else!


#15

Again I’m getting problem,

I changed the baud rate to 115200, the modem is also working properly.

if i put:

i tried this with two SIM. But same result.

Reply me asap.


#16

You probably meant AT+CPIN? (without the equal sign)

Saying “please” has never killed anybody…


#17

Sorry, thanks for your reply.

both

Please reply me asap I’m supporting to my client.

Thanks


#18

In other words, everything has been working correctly all along - you’ve just had it incorrectly configured!

SO the first thing to do is to look-up +CME ERROR : 10 in the manual.

Have you done that?

It’s in the Appendices to the AT Commands Interface Guide


#19

I’m sorry, asking more & more questions. Every thing working fine.
Thanks for your suggestions.

now what is happening is

+CME ERROR: 30 means that No network service

But if i use the SIM in a Mobile phone, it is working properly. I don’t know why.

Is that related with the Baud Rate, that modem is working only with the baud rate 115200.

Please give me any suggestions.

Thanks


#20

Does the SIM require a PIN?

Do you have an antenna properly connected?

Is your service somehow “locked” to a particular mobile?

Definitely not!

As already explained, communication is possible only when both the modem and the terminal have the same settings - if you change the terminal without also cahnging the modem to match, then, of course, they will no longer communicate!