Problem Comunication M1306B


#1

Hi,
I need someone help me because we have a problem between 2 types of modems WaveCOM.
First Case Connection Properly:

If I call from a XTC Modem to a GSM Wavecom Modem (M1206B-ON // WM15467). And I call with atdt <GSM_number> I get connection and I can write amoung them by hyperterminal. The configuration is
at+cgmi
WAVECOM MODEM
OK
at+cgmm
MULTIBAND 900E 1800
OK
at+cgmr
641b09gg.Q2406B 1339080 041604 16:04
OK
at+cgsn
352129000566753
OK
at&v
Q:0 V:1 S0:002 S2:043 S3:013 S4:010 S5:008
+CR:0 +CRC:0 +CMEE:0 +CBST:7,0,1
+SPEAKER:0 +ECHO:0,1 &C:1 &D:2 %C:0
+IPR:9600 +ICF:3,4 +IFC:2,2
OK
at+vgr?
+VGR: 0
OK
at+vgt?
+VGT: 224
OK
at+cbst?
+CBST: 7,0,1
OK
at+fclass?
+FCLASS: 0
OK
at+csns?
+CSNS: 4
OK

Second Case-Problem Comunication
With the same XTC Modem and GSM Modem (Wavecom M1306B // Wm17825). And I call with atdt <GSM_number> I get connection by hyperterminal with the same SIM card number and doing atdt <GSM_number> the problem is when I write in hyperterminal window doesn’t appear in another side. I think is a problem of firmware because in First Case is 041604 16:04 and in these case is 122204 14:53. The configuration of GSM Mobile is:
at+cgmi
WAVECOM MODEM
OK
at+cgmm
MULTIBAND 900E 1800
OK
at+cgmr
650a09gg.Q2406B 1949844 122204 14:53
OK
at+cgsn
354056002493884
OK
at&v
Q:0 V:1 S0:002 S2:043 S3:013 S4:010 S5:008
+CR:0 +CRC:1 +CMEE:1 +CBST:7,0,1
+SPEAKER:0 +ECHO:0,1 &C:1 &D:2 %C:0
+IPR:9600 +ICF:3,4 +IFC:2,2
OK
at+vgr?
+VGR: 0
OK
at+vgt?
+VGT: 224
OK
at+cbst?
+CBST: 7,0,1
OK
at+fclass?
+FCLASS: 0
OK
at+csns?
+CSNS: 4
OK

Could you give me any idea about this happen? If I have to change the firmware GSM mobile in second case, could you indicate me how I can do it?
Best Regards.
Jordi Castilla